Bug 31533 - Black lines while scrolling on HD5850
Summary: Black lines while scrolling on HD5850
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-10 12:28 UTC by Kjell Rune Skaaraas
Modified: 2012-09-03 10:16 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Screenshot showing corruption (363.59 KB, image/jpeg)
2010-11-10 13:18 UTC, Kjell Rune Skaaraas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kjell Rune Skaaraas 2010-11-10 12:28:21 UTC
When I scroll pages (example attached) there are partial or 1-2 lines of black appearing on screen. The initial rendering of the page looks good, and if I continue to scroll the area will look ok. I've not found a simple reproducible case but it happens on any webpage big enough to scroll. Input boxes are particularly badly affected, if I write beyond the size of an input box and have to scoll it is almost always badly corrupted.
Comment 1 Kjell Rune Skaaraas 2010-11-10 13:18:08 UTC
Created attachment 40182 [details]
Screenshot showing corruption

Hmm attaching didn't work?
Comment 2 Alex Deucher 2011-01-27 14:16:38 UTC
Is this still an issue with the latest code in xf86-video-ati git master?
Comment 3 Jos van Wolput 2012-04-13 19:33:15 UTC
(In reply to comment #2)
> Is this still an issue with the latest code in xf86-video-ati git master?

Yes it is, at least when scrolling Iceweasel pages, showing some black or blurred lines.
No such issue when using driver r600g instead of ati in xorg.conf

Hardware: ATI Radeon HD3200 RS780M/RS780MN

Debian Sid with the following packages updated:
Linux Kernel~3.3.0-1.dmz.1-liquorix-amd64
Latest git version of libdrm, libX11, libxcb, libXi, mesa, xserver, xf86-input-evdev and xf86-video-ati.
Comment 4 Jos van Wolput 2012-04-16 21:47:14 UTC
(In reply to comment #2)
> Is this still an issue with the latest code in xf86-video-ati git master?

It's no longer an issue since the 6 commits of 2012-04-16.
Comment 5 Andreas Boll 2012-09-03 10:16:58 UTC
(In reply to comment #4)
> (In reply to comment #2)
> > Is this still an issue with the latest code in xf86-video-ati git master?
> 
> It's no longer an issue since the 6 commits of 2012-04-16.

Closing this bug.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.