Bug 31537 - xserver segfaults in _glXGetDrawable() when firefox goes on some web sites (NULL pointer)
Summary: xserver segfaults in _glXGetDrawable() when firefox goes on some web sites (N...
Status: RESOLVED DUPLICATE of bug 29184
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: 7.4 (2008.09)
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords: patch
Depends on:
Blocks:
 
Reported: 2010-11-10 19:12 UTC by Thierry Vignaud
Modified: 2010-11-11 01:41 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
GDB trace (7.69 KB, text/plain)
2010-11-10 19:12 UTC, Thierry Vignaud
no flags Details
patch fix (729 bytes, patch)
2010-11-10 19:15 UTC, Thierry Vignaud
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Thierry Vignaud 2010-11-10 19:12:53 UTC
Created attachment 40188 [details]
GDB trace

My girlfriend used to make Xserver crash when browsing some sites with firefox or chromium.
See attached GDB trace.
Comment 1 Thierry Vignaud 2010-11-10 19:15:36 UTC
Created attachment 40189 [details] [review]
patch fix 

This patch fixes that crash with xserver-1.7.7.
The crash goes away when switching to xserver-1.9
However I think it still makes sense even if the bug is no more triggered.
Who knows if some other app could trigger the same segfault?
Comment 2 Julien Cristau 2010-11-11 01:41:34 UTC

*** This bug has been marked as a duplicate of bug 29184 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.