Bug 31578 - r600g: enforce minimum stride on render target texture images causes texture corruption on teapot demp.
Summary: r600g: enforce minimum stride on render target texture images causes texture ...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-12 04:01 UTC by Andy Furniss
Modified: 2010-11-18 04:36 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Furniss 2010-11-12 04:01:38 UTC
Running rv670, d-r-t. Tiling on/off doesn't affect.

Mesa demo teapot and openarena has corrupt tectures since -

commit 7fb16423cc325efcdcf6e4954a5ac71d8f96dbf8
Author: Keith Whitwell <keithw@vmware.com>
Date:   Thu Nov 11 16:20:24 2010 +0000

    r600g: enforce minimum stride on render target texture images
    
    Fixes piglit/fbo_readpixels since staging upload changes.
Comment 1 Tilman Sauerbeck 2010-11-15 13:42:24 UTC
Please try this patch:

http://lists.freedesktop.org/archives/mesa-dev/2010-November/004034.html
Comment 2 Andy Furniss 2010-11-15 15:48:20 UTC
(In reply to comment #1)
> Please try this patch:
> 
> http://lists.freedesktop.org/archives/mesa-dev/2010-November/004034.html

That fixes it, thanks.
Comment 3 Tilman Sauerbeck 2010-11-18 00:06:55 UTC
Retry with the tip of the master branch (and throw away the patch I posted).

Commit a23f25eba1fb8919a29efb88ef9e351abcc65b2e should fix this.
Comment 4 Andy Furniss 2010-11-18 04:36:32 UTC
Confirmed, this is fixed now with master tip.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.