Bug 31580 - Remember the size of the gpk-application dialogs
Summary: Remember the size of the gpk-application dialogs
Status: RESOLVED FIXED
Alias: None
Product: PackageKit
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-12 06:53 UTC by Jean-François Fortin Tam
Modified: 2012-01-05 11:08 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-François Fortin Tam 2010-11-12 06:53:23 UTC
The add/remove, update manager, software sources, software log viewer, should all remember their width, height and maximization state.

In Fedora 14, they don't, and it is very annoying to resize up those dialogs everytime I use them: on a high resolution screen (1600x1200 or more), they show up at ridiculously small sizes and are not efficiently using the screen space.
Comment 1 Richard Hughes 2010-11-15 07:17:59 UTC
Isn't this the job of the window manager?
Comment 2 Jean-François Fortin Tam 2010-11-16 05:54:35 UTC
Nope, applications have to handle this individually. We can't expect window managers to remember the attributes of every single window opened on the system; and actually figure out of those attributes need to be remembered in the first place.

I've never seen a window manager that does this, anyway (neither Metacity, Compiz or Mutter remember window sizes/placement).*

Yeah, this means that, over the years, I had to file this bug on countless applications that didn't remember their size (including the GTK filechooser, gnome-search-tool, PiTiVi, GTG, Homebank, etc).

Since gpk-application displays large amounts of information, requires lots of screen space for it, and that this is not very variable from one use to the next, it should definitely remember the sizes. Usually you prepare the window, set its size and then show it (so that there is no visible resizing going on).


*: further research on the subject confirmed that it is not the WM's job:
https://bugzilla.gnome.org/show_bug.cgi?id=144021
https://bugzilla.gnome.org/show_bug.cgi?id=81802
https://bugzilla.gnome.org/show_bug.cgi?id=81108
etc.
Comment 3 Jean-François Fortin Tam 2012-01-05 11:08:57 UTC
Bugs. Sometimes, I fix them.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.