Bug 31590 - Black space between colors on mole hill example
Summary: Black space between colors on mole hill example
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Mesa core (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: mesa-dev
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-12 22:48 UTC by Jaime Rave
Modified: 2011-06-08 07:16 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Screenshot of the issue (39.89 KB, image/png)
2010-11-17 21:23 UTC, Jaime Rave
Details
glxinfo (11.81 KB, text/plain)
2010-11-29 20:20 UTC, Jaime Rave
Details
patch 1 of 2 to fix vbo/display list bugs (2.21 KB, patch)
2011-06-07 15:04 UTC, Brian Paul
Details | Splinter Review
patch 2 of 2 to fix vbo/display list bugs (2.36 KB, patch)
2011-06-07 15:05 UTC, Brian Paul
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jaime Rave 2010-11-12 22:48:31 UTC
the molehill example on the opengl page is not been draw correctly, there are some black pieces that separe the colors.

This is a screenshot of how should be draw:
http://www.opengl.org/resources/code/samples/glut_examples/examples/molehill.jpg

The source code of the example can be found on:
http://www.opengl.org/resources/code/samples/glut_examples/examples/molehill.c
Comment 2 Jaime Rave 2010-11-17 21:23:29 UTC
Created attachment 40357 [details]
Screenshot of the issue

This is on a GM45:

00:02.0 0300: 8086:2a42 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)


OpenGL renderer string: Mesa DRI Mobile Intel® GM45 Express Chipset GEM 20100330 DEVELOPMENT x86/MMX/SSE2
OpenGL version string: 2.1 Mesa 7.10-devel

This is Ubuntu 10.10 and Linux 2.6.36-1-generic-pae

I'm using mesa and Intel drivers from xorg-edgers ppa.
Comment 3 Jaime Rave 2010-11-29 20:20:27 UTC
Created attachment 40654 [details]
glxinfo

I'm attaching my glxinfo. This is also happening with mesa 7.9 (7.9~git20100924-0ubuntu2).
Comment 4 Eric Anholt 2011-06-07 11:19:29 UTC
Not driver-specific -- appears in swrast as well.
Comment 5 Brian Paul 2011-06-07 11:35:35 UTC
With a debug build I'm seeing:
Mesa: User error: GL_INVALID_OPERATION in glEnd

Looks like there's a problem with NURBS and glBegin/End in a display list.
Jaime, perhaps you could try an older version of Mesa and bisect?  I'm pretty sure this used to work.
Comment 6 Jaime Rave 2011-06-07 12:46:04 UTC
(In reply to comment #5)
> With a debug build I'm seeing:
> Mesa: User error: GL_INVALID_OPERATION in glEnd
> 
> Looks like there's a problem with NURBS and glBegin/End in a display list.
> Jaime, perhaps you could try an older version of Mesa and bisect?  I'm pretty
> sure this used to work.
If you can give me some instructions about how to do it, I will be more than glad to help.
Comment 7 Jose Fonseca 2011-06-07 13:28:20 UTC
(In reply to comment #5)
> Looks like there's a problem with NURBS and glBegin/End in a display list.
> Jaime, perhaps you could try an older version of Mesa and bisect?  I'm pretty
> sure this used to work.

I tried as far as mesa_7_5_branch and it still fails.
Comment 8 Brian Paul 2011-06-07 13:32:21 UTC
I've found the problem and have a fix.  Just regression testing...
Comment 9 Brian Paul 2011-06-07 15:04:48 UTC
Created attachment 47692 [details] [review]
patch 1 of 2 to fix vbo/display list bugs
Comment 10 Brian Paul 2011-06-07 15:05:12 UTC
Created attachment 47693 [details] [review]
patch 2 of 2 to fix vbo/display list bugs
Comment 11 Brian Paul 2011-06-07 15:06:22 UTC
The patches I just attached fixes the problem with the molehill demo and fixes another bug/crash that I found with a new piglit test.

No regressions found so I'll probably commit them in a day or so.
Feel free to test in the mean time.
Comment 12 Ian Romanick 2011-06-07 17:45:53 UTC
(In reply to comment #11)
> The patches I just attached fixes the problem with the molehill demo and fixes
> another bug/crash that I found with a new piglit test.
> 
> No regressions found so I'll probably commit them in a day or so.
> Feel free to test in the mean time.

The first patch looks trivially okay.

Reviewed-by: Ian Romanick <ian.d.romanick@intel.com>

I'd have to look at the second one a lot more deeply to fully grok the issues.  It generally looks okay, so if it doesn't cause any piglit regressions:

Acked-by: Ian Romanick <ian.d.romanick@intel.com>
Comment 13 Jose Fonseca 2011-06-08 02:35:23 UTC
Patches look OK to me, Brian.
Comment 14 Brian Paul 2011-06-08 07:16:23 UTC
Fixed with commits
f1cdce95f606584a56eabf3b38eea19ff4c75757
62811057f41bf7c027da6156a44383266c7f3952


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.