Bug 31613 - UI Fonts in Blender are not visible with recent Mesa.
Summary: UI Fonts in Blender are not visible with recent Mesa.
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
: 31615 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-11-13 22:32 UTC by Francis Whittle
Modified: 2010-11-22 15:16 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Francis Whittle 2010-11-13 22:32:31 UTC
All user interface text in Blender 2.55(alpha) and smooth fonts variations of Blender 2.49 is rendered invisible by recent build of Mesa on the r600 gallium driver.

Prerequisites: Mesa current git, any blender 2.55 alpha version including latest svn

Steps to reproduce: Run blender

Expected outcome: Full user interface with fonts correctly rendered.

Actual outcome: No user interface text visible.

git bisect identifies 

commit 63c3e3a3dc73f8a72e0d08ac4453df57bccdfdb9
Author: Keith Whitwell <keithw@vmware.com>
Date:   Tue Nov 9 20:08:45 2010 +0000

    r600: fix my pessimism about PIPE_TRANSFER_x flags

as the culprit.  Rebasing to latest mesa git (master) with this commit reverted works as expected.
Comment 1 Daniel Klaffenbach 2010-11-14 02:58:23 UTC
*** Bug 31615 has been marked as a duplicate of this bug. ***
Comment 2 Francis Whittle 2010-11-15 23:58:49 UTC
The conditions for this failure appear to be related to sync uploads only (with or without readbacks is, at a guess, irrelevant).  At any rate, commenting out the test to use a staged upload in this instance cause the missing text(ures) to reappear.

I'm suspicious that at the end of the big if( use_staging_upload ) block there's a call to r600_copy_to_staging_texture() in the case of PIPE_TRANSFER_READ but apparently no equivalent call for PIPE_TRANSFER_WRITE.
Comment 3 Tilman Sauerbeck 2010-11-22 11:43:48 UTC
Please try again with git master.

Maybe commit d5aadf0d80e8c973ef5cf9d82e97f23f0e3c032b fixed this problem.
Comment 4 Daniel Klaffenbach 2010-11-22 12:14:04 UTC
(In reply to comment #3)
> Please try again with git master.
> 
> Maybe commit d5aadf0d80e8c973ef5cf9d82e97f23f0e3c032b fixed this problem.
I can confirm that this commit fixes the issue in XBMC (Bug 31615).
Comment 5 Francis Whittle 2010-11-22 15:16:26 UTC
Confirmed, that commit fixes it.  Closing.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.