Bug 31704 - [GM45] graphics corruption after hibernate on Thinkpad X301
Summary: [GM45] graphics corruption after hibernate on Thinkpad X301
Status: CLOSED DUPLICATE of bug 28813
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Intel (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Daniel Vetter
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-18 02:00 UTC by Serge Gavrilov
Modified: 2017-07-24 23:06 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Example of screen corruption (187.73 KB, image/png)
2010-11-18 02:02 UTC, Serge Gavrilov
no flags Details
Another example (207.23 KB, image/png)
2010-11-18 02:03 UTC, Serge Gavrilov
no flags Details
Third example (a little bit another kind) (482.56 KB, image/png)
2010-11-18 02:22 UTC, Serge Gavrilov
no flags Details
Xserver log (28.69 KB, application/x-trash)
2010-11-18 06:12 UTC, Serge Gavrilov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Serge Gavrilov 2010-11-18 02:00:18 UTC
Hardware environment: 
Thinkpad X301


To reproduce 00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
	Subsystem: Lenovo Device 20e0
	Flags: bus master, fast devsel, latency 0
	Capabilities: [e0] Vendor Specific Information <?>
	Kernel driver in use: agpgart-intel
	Kernel modules: intel-agp

00:02.0 VGA compatible controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07) (prog-if 00 [VGA controller])
	Subsystem: Lenovo Device 20e4
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at f0000000 (64-bit, non-prefetchable) [size=4M]
	Memory at d0000000 (64-bit, prefetchable) [size=256M]
	I/O ports at 1800 [size=8]
	Expansion ROM at <unassigned> [disabled]
	Capabilities: [90] MSI: Enable- Count=1/1 Maskable- 64bit-
	Capabilities: [d0] Power Management version 3
	Kernel driver in use: i915
	Kernel modules: i915

00:02.1 Display controller: Intel Corporation Mobile 4 Series Chipset Integrated Graphics Controller (rev 07)
	Subsystem: Lenovo Device 20e4
	Flags: bus master, fast devsel, latency 0
	Memory at f0400000 (64-bit, non-prefetchable) [size=1M]
	Capabilities: [d0] Power Management version 3

Software environment:

Gentoo ~x86 
Kernel 2.6.36
xorg-server-1.9.1
xf86-video-intel-2.13.0
mesa-7.9
libdrm-2.4.22
cairo-1.10.0

To reproduce:

1) Start X-session and run MANY application (gvim, firefox, xdvi etc)
2) Work a litle bit 
3) Hibernate
4) Resume
5) If no effect - retry

In my case, the bug is usually unreproducible in the case of hibernate with more or less fresh x-session and 99% reproducible in the when I do some work 
during, e.g., 1 hour and do hibernate afterwards. The googleearth run when hibernate almost always leads to problems.


The character of screen corruption is different in dependence of xorg.conf options. 

General case is 

Section "Device"
        Identifier "Graphics Adapter 1"
        Driver     "intel"
        Option     "AccelMethod" "UXA" 
        Option      "Tiling"        "True"
EndSection

In this case I have some kinds of screen corruption (see screenshots). Sometimes the font corruption disappear after next hibernate cycle, but usually this does not help.

In the case 
        Option      "Tiling"        "False"
I never saw screen corruption. But instead of this after resume I obtain black screen on the corresponding console (where Xserver is run). This (black screen) cannot be fixed somehow, the only method to fix is to restart X-server.

Third case is Option "Shadow" "True". In this case I never saw the problems, but I did not investigate this case much.

Please, indicate what kind of additional info can I provide to fix this problem.
Thanks!
Comment 1 Serge Gavrilov 2010-11-18 02:02:14 UTC
Created attachment 40360 [details]
Example of screen corruption
Comment 2 Serge Gavrilov 2010-11-18 02:03:42 UTC
Created attachment 40361 [details]
Another example
Comment 3 Serge Gavrilov 2010-11-18 02:22:01 UTC
Created attachment 40364 [details]
Third example (a little bit another kind)
Comment 4 Serge Gavrilov 2010-11-18 06:12:44 UTC
Created attachment 40385 [details]
Xserver log
Comment 5 Serge Gavrilov 2010-11-22 05:48:59 UTC
I investigate more the case "Shadow" "True". In this case hibernate absolutely stable - no any artifacts after resume. Only one problem (clearly another bug) Xserver crashes when connecting to an external monitor (unreproducible with Shadow False).

Please help - for the time being there no working configuration.
Comment 6 Serge Gavrilov 2010-11-22 08:56:19 UTC
When an external monitor is connected I cannot reproduce graphics corruption (with tiling). Instead I have blank screen after resume like in the case without an external monitor and Tiling=False.
Comment 7 Serge Gavrilov 2010-11-22 08:57:37 UTC
I mean an external monitor is connected during the hibernate cycle
Comment 8 Serge Gavrilov 2010-11-23 01:04:00 UTC
Could anybody comment somehow the bug status? Is this a known problem? Is this related to famous A17 issue? Is any additional information required to resolve the bug?
Comment 9 Chris Wilson 2012-02-20 11:57:17 UTC
Another swizzling issue? Recent kernels shouldn't evict everything from memory upon suspend and so the issue should be less apparent, if this were the swizzled swap issue.
Comment 10 Daniel Vetter 2012-02-20 13:25:43 UTC
The detiling pattern on the big wallpaper is the same as on the the other bugs (bug #45092 and bug #28813) and also nicely aligned to X-tiled tiles. Closing as a dupe of the gm45 one.

The black screen is a totally different bug, please file that as a separate issue.

*** This bug has been marked as a duplicate of bug 28813 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.