Bug 3174 - Dual head not detected for GE Force FX 5200
Summary: Dual head not detected for GE Force FX 5200
Status: RESOLVED DUPLICATE of bug 5190
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nVidia (open) (show other bugs)
Version: 6.8.1
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2005-05-01 23:31 UTC by John Leys
Modified: 2006-01-20 11:28 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description John Leys 2005-05-01 23:31:21 UTC
My dual head video card is not detected by SuSE sax2.
Comment 1 Alex Deucher 2005-05-04 06:42:41 UTC
The xorg nv driver does not support dualhead.  You will need to use nvidia's
binary driver to use dualhead.
Comment 2 Allen Van Gelder 2005-08-09 15:29:59 UTC
(In reply to comment #1)
> The xorg nv driver does not support dualhead.  You will need to use nvidia's
> binary driver to use dualhead.
Looking at the source code, it appears that the INTENTION is for nv to
support dualhead, or multi-head, but I agree that the fact is you just get
an error message "Requested entity is already in use!" and the driver gives up.
My question is whether this is because there are serious difficulties
so someone just put in the test to kill off multi-head, or is it an oversight?
We have had problems trying to install nvidia's driver, so we are wondering
whether making nv work is a reasonable idea, or an "previously unsolved" problem?
Comment 3 Alex Deucher 2005-08-09 23:07:07 UTC
(In reply to comment #2)
> (In reply to comment #1)
> > The xorg nv driver does not support dualhead.  You will need to use nvidia's
> > binary driver to use dualhead.
> Looking at the source code, it appears that the INTENTION is for nv to
> support dualhead, or multi-head, but I agree that the fact is you just get
> an error message "Requested entity is already in use!" and the driver gives up.
> My question is whether this is because there are serious difficulties
> so someone just put in the test to kill off multi-head, or is it an oversight?
> We have had problems trying to install nvidia's driver, so we are wondering
> whether making nv work is a reasonable idea, or an "previously unsolved" problem?
> 


The nv driver doesn't officially support dualhead.  I haven't looked to closely
at the code, but I believe Mark added some code to handle a certain degree of
crtc control, but he never added full dualhead support, perhaps it is nvidia's
policy to not support it in the nv driver.  If there is enough information in
the code to support dualhead, then by all means post a patch.  I can advise you
on what needs to be done to support dualhead in general.  The open source BEOS
nv driver supports dualhead (I believe it was based on the xfree/xorg driver),
so it should be possible.
Comment 4 Adam Jackson 2006-01-21 06:28:01 UTC

*** This bug has been marked as a duplicate of 5190 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.