Bug 31870 - [evergreen] Graphics freezes when selecting Atlantis from XScreenSaver
Summary: [evergreen] Graphics freezes when selecting Atlantis from XScreenSaver
Status: RESOLVED DUPLICATE of bug 33139
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-11-23 11:14 UTC by Jure Repinc
Modified: 2011-01-31 20:04 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jure Repinc 2010-11-23 11:14:29 UTC
Hardware: ATI Mobility Radeon HD 5470
Software:
XScreenSaver 5.12
KDE SC 4.5.3
Linux 2.6.37-RC3
Xorg Server 1.9.2.901
Mesa, libdrm, xf86-vide-ati all from git

Steps to reproduce:
1. Open KDE Screen Saver settings module
2. find Atlantis in OpenGL Screen Savers
3. Click on it

Actual result:
Mouse stops moving and graphics freezes. I can't use Ctrl+Alt+F1 to switch to console. I can still SSH into that machine and can't see any process using much CPU.

Expected:
A preview of Atlantis should be shown in the preview area.

Reproducable: Always
Comment 1 Jure Repinc 2010-12-26 16:21:50 UTC
On 2010-12-26 I updated the code from git and today it didn't freeze anymore with atlantis, but it now hanged when selecting Pipes screensaver (I just kept selecteing and testing all OpenGL screensavers).
Comment 2 Rubén Fernández 2011-01-19 19:52:07 UTC
I have the exact same bug in an HD5750; it also used to freeze specifically
with atlantis, and now randomly

GPU: ATI Technologies Inc Juniper HDMI Audio [Radeon HD 5700 Series]
Kernel: 2.6.38
libdrm-2.4.23
xf86-video-ati git 57fbddfc21d8c6794f378489b764cc2a0ad4a48c
Mesa git 3ee60a3558a3546b3c3a0a9732d384afcf02994a
X.Org X Server 1.9.0
XScreenSaver 5.12

To reproduce:
1) Run xscreensaver-demo
2) Do a preview of opengl screensavers several times

Eventually, you'll get to some screensaver that runs fine, but, after closing it,
some second later, the cursor freezes.
Comment 3 Jure Repinc 2011-01-25 13:55:23 UTC
I have upgraded to kernel 2.6.38-rc2 and latest MESA git and the freeze is still here. Although now after some time graphics resets and then almost immidiately locks up again. I managed to close the screensaver dialog during this short time and then it didn't freeze anymore. So I took a look at dmesg and now I get this in it:

[  424.580259] radeon 0000:01:00.0: GPU lockup CP stall for more than 10000msec
[  424.580267] ------------[ cut here ]------------
[  424.580282] WARNING: at drivers/gpu/drm/radeon/radeon_fence.c:248 radeon_fence_wait+0x366/0x3d0()
[  424.580288] Hardware name: eME640G         
[  424.580293] GPU lockup (waiting for 0x00013ABE last fence id 0x00013AB6)
[  424.580297] Modules linked in: lib80211_crypt_tkip wl(P) uvcvideo k10temp i2c_piix4 wmi
[  424.580316] Pid: 2632, comm: atlantis Tainted: P        W   2.6.38-rc2+ #5
[  424.580321] Call Trace:
[  424.580333]  [<ffffffff81044b0a>] ? warn_slowpath_common+0x7a/0xb0
[  424.580342]  [<ffffffff81044be1>] ? warn_slowpath_fmt+0x41/0x50
[  424.580351]  [<ffffffff813136d6>] ? radeon_fence_wait+0x366/0x3d0
[  424.580361]  [<ffffffff81060b90>] ? autoremove_wake_function+0x0/0x40
[  424.580369]  [<ffffffff81313ebc>] ? radeon_sync_obj_wait+0xc/0x10
[  424.580377]  [<ffffffff812de3b9>] ? ttm_bo_wait+0xf9/0x1b0
[  424.580385]  [<ffffffff812e15b3>] ? ttm_bo_move_accel_cleanup+0xa3/0x2b0
[  424.580393]  [<ffffffff81314148>] ? radeon_move_blit.clone.1+0x118/0x180
[  424.580401]  [<ffffffff813143ba>] ? radeon_move_ram_vram.clone.3+0xda/0x110
[  424.580409]  [<ffffffff812defa3>] ? ttm_bo_list_ref_sub+0x23/0x30
[  424.580417]  [<ffffffff812e4323>] ? ttm_eu_list_ref_sub+0x33/0x50
[  424.580424]  [<ffffffff81314558>] ? radeon_bo_move+0x168/0x170
[  424.580432]  [<ffffffff812df988>] ? ttm_bo_handle_move_mem+0x138/0x370
[  424.580440]  [<ffffffff812e0aae>] ? ttm_bo_move_buffer+0x13e/0x150
[  424.580447]  [<ffffffff812defa3>] ? ttm_bo_list_ref_sub+0x23/0x30
[  424.580455]  [<ffffffff812e4323>] ? ttm_eu_list_ref_sub+0x33/0x50
[  424.580462]  [<ffffffff812e0b4e>] ? ttm_bo_validate+0x8e/0x120
[  424.580469]  [<ffffffff81315447>] ? radeon_bo_list_validate+0x77/0xd0
[  424.580477]  [<ffffffff8132d25e>] ? radeon_cs_parser_relocs+0x20e/0x250
[  424.580484]  [<ffffffff8132d700>] ? radeon_cs_ioctl+0xa0/0x1e0
[  424.580495]  [<ffffffff810c771f>] ? handle_pte_fault+0x7f/0x890
[  424.580504]  [<ffffffff812c949c>] ? drm_ioctl+0x3dc/0x4d0
[  424.580512]  [<ffffffff810c55ef>] ? __pte_alloc+0x8f/0x120
[  424.580519]  [<ffffffff8132d660>] ? radeon_cs_ioctl+0x0/0x1e0
[  424.580529]  [<ffffffff8102c64c>] ? do_page_fault+0x1ac/0x450
[  424.580538]  [<ffffffff81105c04>] ? do_vfs_ioctl+0x94/0x620
[  424.580547]  [<ffffffff81106219>] ? sys_ioctl+0x89/0x90
[  424.580556]  [<ffffffff81002d3b>] ? system_call_fastpath+0x16/0x1b
[  424.580562] ---[ end trace e589195ec1430fd8 ]---
[  424.581862] radeon 0000:01:00.0: GPU softreset 
[  424.581869] radeon 0000:01:00.0:   GRBM_STATUS=0xB2733828
[  424.581875] radeon 0000:01:00.0:   GRBM_STATUS_SE0=0x1C000007
[  424.581881] radeon 0000:01:00.0:   GRBM_STATUS_SE1=0x00000007
[  424.581887] radeon 0000:01:00.0:   SRBM_STATUS=0x200000C0
[  424.581949] radeon 0000:01:00.0:   GRBM_SOFT_RESET=0x00007F6B
[  424.582070] radeon 0000:01:00.0:   GRBM_STATUS=0x00003828
[  424.582078] radeon 0000:01:00.0:   GRBM_STATUS_SE0=0x00000007
[  424.582085] radeon 0000:01:00.0:   GRBM_STATUS_SE1=0x00000007
[  424.582092] radeon 0000:01:00.0:   SRBM_STATUS=0x200000C0
[  424.583099] radeon 0000:01:00.0: GPU reset succeed
[  424.605117] radeon 0000:01:00.0: WB enabled
[  424.621222] [drm] ring test succeeded in 1 usecs
[  424.621251] [drm] ib test succeeded in 1 usecs
Comment 4 Rubén Fernández 2011-01-29 15:43:58 UTC
The kernel patch that fixes bug #33139 also solved this bug for me;
it's possible they were the same. Try applying this patch to your kernel:

https://bugs.freedesktop.org/attachment.cgi?id=42615

and see if it helps
Comment 5 Jure Repinc 2011-01-30 19:47:55 UTC
I updated the kernel from git and it appears to be fixed.
Comment 6 Rubén Fernández 2011-01-31 20:04:00 UTC

*** This bug has been marked as a duplicate of bug 33139 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.