Bug 32045 - Weird rendering from a test program
Summary: Weird rendering from a test program
Status: RESOLVED DUPLICATE of bug 29420
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r300 (show other bugs)
Version: 7.9
Hardware: Other Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-02 05:34 UTC by Hicham HAOUARI
Modified: 2010-12-02 06:33 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hicham HAOUARI 2010-12-02 05:34:09 UTC
First of all, I am sorry for not being able to provide a source code for the test program.

This program is available at : http://frictionalgames.com/forum/thread-3656-post-30293.html#pid30293

It appears that some textures coordinates are misread, which leads to some upside down rendering.

I am attaching the output of the program. You can find how the images should look in the image "feat_test_images_round2.jpg".
Comment 1 Hicham HAOUARI 2010-12-02 05:40:11 UTC
here is the output with the image to compare with :

http://hicham.fedorapeople.org/amnesia_tdd/output.tar.bz2
Comment 2 Pavel Ondračka 2010-12-02 06:19:29 UTC
Duplicate of bug 29420?
Comment 3 Edward Rudd 2010-12-02 06:33:23 UTC

*** This bug has been marked as a duplicate of bug 29420 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.