Bug 32261 - Deadlock in _XReply and XNextEvent
Deadlock in _XReply and XNextEvent
Status: RESOLVED DUPLICATE of bug 30450
Product: xorg
Classification: Unclassified
Component: Lib/Xlib
unspecified
x86 (IA32) Linux (All)
: high major
Assigned To: Xorg Project Team
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-09 01:38 UTC by TS
Modified: 2011-03-14 17:39 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description TS 2010-12-09 01:38:02 UTC
I am having an multi-thread application which hangs after I upgrade to FC14. There is one thread consistently calling XNextEvent for X Window event; while another thread needs to communicate with X Server for some operation on the X Display which will wait for _XReply. Deadlock seems to be happens in the xlib/xcb library in this situation. 

The version of xlib and xcb are: 
libX11-1.3.4
libxcb-1.7.1

I try to upgrade to libX11-1.4.0 but this issue still occurs. However, the application has no problem after I downgrade to libX11-1.3.3.
Comment 1 Rami Ylimaki 2010-12-09 07:43:16 UTC
Discussed previously here: http://lists.freedesktop.org/archives/xcb/2010-December/006655.html.
Comment 2 Jamey Sharp 2011-03-14 17:39:22 UTC

*** This bug has been marked as a duplicate of bug 30450 ***