Bug 3234 - Xorg crashes when DRI is enabled and there is no DRI section in config file
Summary: Xorg crashes when DRI is enabled and there is no DRI section in config file
Status: VERIFIED INVALID
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/DDX/Xorg (show other bugs)
Version: 6.8.2
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords: want-backtrace
Depends on:
Blocks:
 
Reported: 2005-05-07 08:02 UTC by Michal Suchanek
Modified: 2006-04-24 14:37 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Michal Suchanek 2005-05-07 08:02:33 UTC
By default, the dri device is not accessible, and X -configure does not create a
DRI section.
Unless one manually adds the section that allows access, the X server crashes as
soon as an openGL application is started (ie glxgears).

afaict this section is not documented anywhere in the xorg installed files (man
pages, readme). Only xorg.conf.html references non-existent README.DRI.

Since this is something that goes into xorg.conf file and is needed for normal
operation it should be documented somewhere in the distribution.
Comment 1 Adam Jackson 2005-07-03 14:48:04 UTC
starting with the 6.8.99.14 snapshot, on linux systems, the X server can print
its own backtrace when it crashes.  please confirm that these bugs are still
valid with 6.8.99.14 or later, and if they are please attach a the server log
from the crash.
Comment 2 Adam Jackson 2005-10-03 18:19:58 UTC
reporter: ping.  please try to reproduce this on a recent server build.

in my testing this has not been a problem.
Comment 3 Erik Andren 2006-04-23 06:49:18 UTC
Closing this bug due to the lack activity. Please reopen if the bug still
persists      using a current version of xorg.
Comment 4 Michal Suchanek 2006-04-25 07:37:41 UTC
crash no longer reproducible with Xorg 7


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.