Bug 32430 - /etc/X11/xorg.conf "Screen" & "Monitor" sections not obeyed
Summary: /etc/X11/xorg.conf "Screen" & "Monitor" sections not obeyed
Status: RESOLVED WONTFIX
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Dan Nicholson
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-15 20:13 UTC by Felix Miata
Modified: 2019-07-20 00:47 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf file that worked for mga in 1.8.0 (6.62 KB, text/plain)
2010-12-15 20:13 UTC, Felix Miata
no flags Details
Xorg.0.log from using attachment 41159 and resulting in 800x600 @96 DPI (29.41 KB, text/plain)
2010-12-15 20:19 UTC, Felix Miata
no flags Details
Xorg.0.log from configuration via /etc/X11/xorg.conf.d/ resulting in 1600x1200 @120 DPI (28.16 KB, text/plain)
2010-12-15 20:19 UTC, Felix Miata
no flags Details
xfree86: Use last Screen section found to prefer xorg.conf (1.94 KB, patch)
2010-12-16 06:15 UTC, Dan Nicholson
no flags Details | Splinter Review
xfree86: Use last Screen section found to prefer xorg.conf (#32430) (3.27 KB, patch)
2011-01-07 07:03 UTC, Dan Nicholson
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Felix Miata 2010-12-15 20:13:12 UTC
Created attachment 41159 [details]
xorg.conf file that worked for mga in 1.8.0

To reproduce:
1-create /etc/X11/xorg.conf file that worked as expected in 1.8.0 to produce e.g. 1600x1200@60 @ appropriate DPI on mga via DisplaySize, Modes, etc.
2-startx in 1.9.2 running 2.6.36 or 2.6.37 kernel

Actual results:
1-X starts in 800x600@96DPI

Expected results:
1-X starts in 1600x1200@60Hz@120DPI

Notes:
1-recent personal tests made only using openSUSE and KDE
2-placing screen and display parameters that used to work in xorg.conf into /etc/X11/xorg.conf.d/ files produces expected results
3-I've replied to multiple mailing list threads where the fix involved applying #3 above and chips other than mga.
4-IIRC, this has happened personally also using Intel and/or ATI video, but I'll need some time if it's necessary to confirm this.
Comment 1 Felix Miata 2010-12-15 20:19:07 UTC
Created attachment 41160 [details]
Xorg.0.log from using attachment 41159 [details] and resulting in 800x600 @96 DPI
Comment 2 Felix Miata 2010-12-15 20:19:21 UTC
Created attachment 41161 [details]
Xorg.0.log from configuration via /etc/X11/xorg.conf.d/ resulting in 1600x1200 @120 DPI
Comment 3 Dan Nicholson 2010-12-16 06:15:07 UTC
Created attachment 41171 [details] [review]
xfree86: Use last Screen section found to prefer xorg.conf

Can you try out this patch? I didn't test it, but I think it should give you the last Screen section found.
Comment 4 Felix Miata 2010-12-16 06:59:34 UTC
Looks like answer to that is no, since I don't see any xf86Config.c file anywhere in /. Compiling binaries from source is over my head, as is utilizing the openSUSE Build Service. If someone else could apply that patch to whatever 32bit binary the patch affects from http://download.opensuse.org/factory/repo/oss/suse/, using the OBS if necessary, I could try that.
Comment 5 Dan Nicholson 2010-12-16 11:59:36 UTC
Hmm. You may want to open a suse bug referencing this one and point the suse maintainer to this patch. I don't have the ability to build suse packages, but this patch should apply to the version you showed (I think).
Comment 6 Felix Miata 2010-12-29 16:23:59 UTC
https://bugzilla.novell.com/show_bug.cgi?id=661536 marked this fixed. Since installing later packages on one mga system, the applied patch seems to have done its job. :-)
Comment 7 Felix Miata 2010-12-29 20:29:09 UTC
Works on Radeon rv200 too.
Comment 8 Dan Nicholson 2010-12-30 06:24:19 UTC
Great. I'm going to throw it by the mailing list with references to the bugs in the commit message in the next couple days.
Comment 9 Stefan Dirsch 2011-01-02 22:45:48 UTC
The patch crashes the Xserver during startup immediately when there is no screen section specified at all (neither in a xorg.conf nor in any of the potential xorg.conf.d directories). I fixed it that way:

@@ -42,7 +42,7 @@
        }
        conf_screen = s;
        from = X_CMDLINE;
-+    } else {
++    } else if (conf_screen) {
 +      /* Use the last Screen in the list */
 +      s = conf_screen;
 +      while (s->list.next)
Comment 10 Dan Nicholson 2011-01-07 07:03:09 UTC
Created attachment 41746 [details] [review]
xfree86: Use last Screen section found to prefer xorg.conf (#32430)

Good catch. Here's a new patch which also catches the case where you have a ServerLayout but no Screen section specified. Seems to work for me. I'm going to send this one to the list.
Comment 11 Stefan Dirsch 2011-03-29 03:52:27 UTC
Dan, did you ever send your patch to the list? Any outcome? openSUSE includes your patch now since January, i.e. also in openSUSE 11.4.
Comment 12 Dan Nicholson 2011-03-29 05:19:48 UTC
I did. It was pretty much NAKed.

http://lists.x.org/archives/xorg-devel/2011-January/018086.html

Michel and Julien make a good point. Changing the behavior now could break someone else's xorg.conf. Feel free to open it up for discussion again, but I've kind of come around to their side of the fence. If you have Screen and Monitor sections that you definitely want to use, put them in a ServerLayout. And if you're a distro, beware that adding Screen sections could break someone's configuration.
Comment 13 Stefan Dirsch 2011-03-29 06:33:15 UTC
Ok. Thanks for the background, Dan!
Comment 14 Stefan Dirsch 2018-07-17 09:56:58 UTC
Unfortunately this became a WONTFIX. See comment #12 and discussion on http://lists.x.org/archives/xorg-devel/2011-January/018086.html

Closing as such.
Comment 15 emadyassen1998@yahoo.com (Spammer; Account disabled) 2019-07-20 00:47:31 UTC Comment hidden (spam)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.