Bug 32460 - [softpipe] piglit texwrap 1D regression
[softpipe] piglit texwrap 1D regression
Status: CLOSED FIXED
Product: Mesa
Classification: Unclassified
Component: Other
git
x86 (IA32) Linux (All)
: medium normal
Assigned To: Brian Paul
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-16 16:54 UTC by Vinson Lee
Modified: 2011-01-03 11:30 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vinson Lee 2010-12-16 16:54:38 UTC
mesa: 9d9f8aba0aa51f707ac1d451fb8a89bb95676ab1 (master)

piglit OpenGL 1.1 texwrap-1D test now fails but previously passed on softpipe.


$ ./bin/texwrap 1D -auto
Parameter: 1D
Using TEXTURE_1D.

Hint: If you only fail CLAMP and CLAMP_TO_BORDER tests, the border color is wrong.

Testing NEAREST: REPEAT
Testing NEAREST: CLAMP
Testing NEAREST: CLAMP_TO_EDGE
Testing NEAREST: CLAMP_TO_BORDER
Testing NEAREST: MIRRORED_REPEAT
Testing NEAREST: MIRROR_CLAMP_EXT
Testing NEAREST: MIRROR_CLAMP_TO_EDGE_EXT
Testing NEAREST: MIRROR_CLAMP_TO_BORDER_EXT
Testing LINEAR: REPEAT
Testing LINEAR: CLAMP
Testing LINEAR: CLAMP_TO_EDGE
Testing LINEAR: CLAMP_TO_BORDER
Testing LINEAR: MIRRORED_REPEAT
Testing LINEAR: MIRROR_CLAMP_EXT
Testing LINEAR: MIRROR_CLAMP_TO_EDGE_EXT
Testing LINEAR: MIRROR_CLAMP_TO_BORDER_EXT
Testing NEAREST with swizzling: REPEAT
Testing NEAREST with swizzling: CLAMP
Testing NEAREST with swizzling: CLAMP_TO_EDGE
Testing NEAREST with swizzling: CLAMP_TO_BORDER
Probe at (273,36) @ 0,0
  Expected: 127 25 229 204
  Observed: 229 128 26 204
Testing NEAREST with swizzling: MIRRORED_REPEAT
Testing NEAREST with swizzling: MIRROR_CLAMP_EXT
Testing NEAREST with swizzling: MIRROR_CLAMP_TO_EDGE_EXT
Testing NEAREST with swizzling: MIRROR_CLAMP_TO_BORDER_EXT
Probe at (629,36) @ 0,0
  Expected: 127 25 229 204
  Observed: 229 128 26 204
Testing LINEAR with swizzling: REPEAT
Testing LINEAR with swizzling: CLAMP
Probe at (95,125) @ 0,0
  Expected: 63 140 114 204
  Observed: 115 191 13 204
Testing LINEAR with swizzling: CLAMP_TO_EDGE
Testing LINEAR with swizzling: CLAMP_TO_BORDER
Probe at (273,125) @ 0,0
  Expected: 127 25 229 204
  Observed: 229 128 26 204
Testing LINEAR with swizzling: MIRRORED_REPEAT
Testing LINEAR with swizzling: MIRROR_CLAMP_EXT
Probe at (451,125) @ 0,0
  Expected: 191 12 242 178
  Observed: 242 64 140 179
Testing LINEAR with swizzling: MIRROR_CLAMP_TO_EDGE_EXT
Testing LINEAR with swizzling: MIRROR_CLAMP_TO_BORDER_EXT
Probe at (629,125) @ 0,0
  Expected: 127 25 229 204
  Observed: 229 128 26 204
PIGLIT: {'result': 'fail' }
Comment 1 Vinson Lee 2010-12-16 16:59:39 UTC
c62bb90d6a864468fe1a717aebb9c1a9c43bf3c8 is the first bad commit
commit c62bb90d6a864468fe1a717aebb9c1a9c43bf3c8
Author: Brian Paul <brianp@vmware.com>
Date:   Tue Dec 14 13:01:00 2010 -0700

    softpipe: do texture swizzle during texture sampling
    
    Instead of when we read texture tiles.  Now swizzling happens after
    the shadow depth compare step.  This fixes the piglit glsl-fs-shadow2d*
    tests (except for proj+bias because of a GLSL bug).

:040000 040000 4d10bf9229786b1d75b419548d83adba7fb5751b e44f13680425a59196a9133aec126350dd21c955 M	src
bisect run success
Comment 2 Brian Paul 2010-12-16 17:20:25 UTC
Fixed with commit 42a0967a36ff3331de96289125243e6afeb5d560

I actually found this before the bug report.  I almost beat you to it!
Comment 3 Vinson Lee 2011-01-03 11:30:23 UTC
mesa: ada9c78c29ef11720d464211c098b740f8aa11a4 (master)

Verified fixed.