Bug 32615 - tp-ssip sends REGISTER messages in a loop with ever increasing number of Contact headers
Summary: tp-ssip sends REGISTER messages in a loop with ever increasing number of Cont...
Status: RESOLVED NOTOURBUG
Alias: None
Product: Telepathy
Classification: Unclassified
Component: rakia (show other bugs)
Version: git master
Hardware: Other All
: medium normal
Assignee: Mikhail Zabaluev
QA Contact: Telepathy bugs list
URL: https://sourceforge.net/tracker/index...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-23 11:43 UTC by Olivier Crête
Modified: 2011-01-11 10:45 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Olivier Crête 2010-12-23 11:43:56 UTC
I can reproduce this with Collabora's Freeswitch server and it eats all my battery and loads of bandwidth. So this is kind of critical.

Freeswitch side bug:
http://jira.freeswitch.org/browse/FS-678

But from the log (I didn't investigate further), it looks like a bug in tp-ssip.

I've only tested with the version that is on the N900 which means sofiasip 1.12.10-0maemo5 and tp-ssip 0.6.2-0maemo4

I'm not sure how to reproduce it reliably..
Comment 1 Mikhail Zabaluev 2010-12-27 09:26:24 UTC
This is in fact a sofia-sip bug.
Comment 2 Mikhail Zabaluev 2010-12-29 07:45:25 UTC
A fix can be tested using this branch:
http://gitorious.org/~mzabaluev/sofia-sip/mzabaluev-sofia-sip/commits/fix-ob-contacts
Comment 3 Mikhail Zabaluev 2011-01-11 10:45:01 UTC
The fix is merged into sofia-sip master head.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.