Bug 32639 - [RADEON::R300C] artifacts on dinoshade, neverball and other GL softwares
Summary: [RADEON::R300C] artifacts on dinoshade, neverball and other GL softwares
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/r300 (show other bugs)
Version: 7.10
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-12-24 07:01 UTC by alessandro.sturniolo
Modified: 2011-10-15 11:14 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Dinoshade with artifacts (18.24 KB, image/jpeg)
2010-12-24 07:01 UTC, alessandro.sturniolo
Details
Neverball with artifacts (82.49 KB, image/jpeg)
2010-12-24 07:02 UTC, alessandro.sturniolo
Details
glxinfo (4.87 KB, text/plain)
2010-12-24 07:03 UTC, alessandro.sturniolo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description alessandro.sturniolo 2010-12-24 07:01:20 UTC
Created attachment 41424 [details]
Dinoshade with artifacts

After the commit 5ee270820ba8dc7bfc6be5812f02c66f4a76f705, as you can see from the attached snapshots, softwares like Mesa demo dinoshade, neverball or SecondLife, render artifacts on the scene.
This bug is present in every release after version 7.7.1 (7.7.1 excluded).
Before this commit the artifacts are not presents. It is not present also when gallium is enabled.
My system is a Linux openSuSE 11.3 (kernel 2.6.34.7-0.5-default SMP) on an AMD Athlon 64 X2. Graphic card is a Radeon X1200 (RS690).
Comment 1 alessandro.sturniolo 2010-12-24 07:02:16 UTC
Created attachment 41425 [details]
Neverball with artifacts
Comment 2 alessandro.sturniolo 2010-12-24 07:03:06 UTC
Created attachment 41426 [details]
glxinfo
Comment 4 Jerome Glisse 2011-03-07 11:23:41 UTC
Do you still have issue with lastest mesa ? Also please try r300g the classic r300 driver is no longer actively supported
Comment 5 alessandro.sturniolo 2011-03-19 14:49:17 UTC
I've recently update my system to openSuSE 11.4, so I've installed recent Mesa 7.10 (RPM package is Mesa-7.10-59.3 from http://download.opensuse.org/repositories/X11:/XOrg/openSUSE_11.4 repository).

The package is compiled with gallium enabled by default, then the artifacts aren't present.

Instead when I recompile the package from openSuSE SRPM sources with gallium disabled, the artifacts reappear.

I've tested with r300 driver, because I was not able to found and enable r300g on Mesa 7.10.
Comment 6 alessandro.sturniolo 2011-03-19 14:54:54 UTC
I've google a little bit.
The r300g is the gallium driver for r300?

The problem is that gallium actually is too slow. On my notebook, is much faster the swrast driver, but if I disable gallium, I get the artifacts.

At this time, on this kind of hardware (I've a Radeon X1200), gallium is almost unusable.
Comment 7 Alex Deucher 2011-03-19 15:03:59 UTC
(In reply to comment #6)
> I've google a little bit.
> The r300g is the gallium driver for r300?
> 
> The problem is that gallium actually is too slow. On my notebook, is much
> faster the swrast driver, but if I disable gallium, I get the artifacts.
> 
> At this time, on this kind of hardware (I've a Radeon X1200), gallium is almost
> unusable.

enable llvm in your mesa build:
--enable-gallium-llvm
Comment 8 alessandro.sturniolo 2011-03-19 18:13:37 UTC
Ok, I've enabled gallium with llvm support. Now neverball, from 1 fps with gallium (2 fps with swrast) is jumped to 15 fps, and it is more playable. Thanks :-)
But the performance gap with r300 driver without gallium (from Mesa 7.6 sources) is of a factor of about 2~2.5 times and on limited hardware like my Radeon X1200 this is frustrating :-(
The fglrx driver, dropped support for this family of video card from March 2009.
Comment 9 Fabio Pedretti 2011-03-21 01:39:02 UTC
You could try with mesa from git master:
git pull git://anongit.freedesktop.org/mesa/mesa
It should be faster.
Comment 10 Fabio Pedretti 2011-03-21 01:43:48 UTC
git clone git://anongit.freedesktop.org/mesa/mesa
Comment 11 almos 2011-10-15 11:14:07 UTC
I can't comment on SecondLife, but Neverball and the dinoshade demo render correctly on my rv350 with current r300g. I'm closing this bug, as the r300c is not supported anymore. Alessandro, please upgrade your system to the 7.11 release of Mesa.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.