Bug 32682 - Inverted check in tseng driver makes it fail to detect card
Inverted check in tseng driver makes it fail to detect card
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Driver/Tseng Labs
git
Other Linux (All)
: medium major
Assigned To: Xorg Project Team
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-27 05:53 UTC by BALATON Zoltan
Modified: 2011-06-11 03:54 UTC (History)
0 users

See Also:


Attachments
Patch correcting typo in TsengGetFbAddress (700 bytes, patch)
2010-12-27 05:55 UTC, BALATON Zoltan
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description BALATON Zoltan 2010-12-27 05:53:26 UTC
Due to a typo in TsengGetFbAddress it is unable to get framebuffer base address and thus fails to load with an error message saying "No valid Framebuffer address in PCI config space" although previously it does print the correct framebuffer address. The attached patch corrects this and makes the driver work again.
Comment 1 BALATON Zoltan 2010-12-27 05:55:05 UTC
Created attachment 41473 [details] [review]
Patch correcting typo in TsengGetFbAddress
Comment 2 Julien Cristau 2011-06-11 03:54:05 UTC
Committed, finally.  Thanks for the patch!

commit 542e65deaf834c3d58c44064206445e4d18f6daa
Author: BALATON Zoltan <balaton@eik.bme.hu>
Date:   Sat Jun 11 12:50:16 2011 +0200

    Fix regression from pciaccess conversion (bug#32682)
    
    Due to a typo in TsengGetFbAddress it is unable to get framebuffer base
    address and thus fails to load with an error message saying "No valid
    Framebuffer address in PCI config space" although previously it does
    print the correct framebuffer address.
    
    Signed-off-by: Julien Cristau <jcristau@debian.org>