Bug 32694 - [SNB libva]when play a MPEG2 file and resize it, it will cause GPU hang occasionally
[SNB libva]when play a MPEG2 file and resize it, it will cause GPU hang occas...
Status: VERIFIED FIXED
Product: xorg
Classification: Unclassified
Component: Driver/intel
unspecified
x86 (IA32) Linux (All)
: medium major
Assigned To: haihao
Hai
:
: 32593 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-12-27 21:18 UTC by Hai
Modified: 2011-03-22 19:48 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (33.49 KB, text/plain)
2011-01-10 22:19 UTC, Hai
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hai 2010-12-27 21:18:06 UTC
System Environment:
--------------------------
Libdrm:        (master)2.4.23-4-gbad5242a59aa8e31cf10749e2ac69b3c66ef7da0
Mesa:        (7.10)612e26e82c60809ab9c81213f39fbe527284af9f
Xserver:   
(server-1.9-branch)xorg-server-1.9.3-6-ga2c674b75d3b1a663bece6f6e2e34c3e71e6be55
Xf86_video_intel:   
(master)2.13.902-5-g1ac2e04023f84dbf1f3db2ecad1cadd159aa614d
Cairo:        (master)cf0a4ed862d93b7e6d7d26942cfe98a50beccd4c
Kernel:    (drm-intel-next) 8d5203ca62539c6ab36a5bc2402c2de1de460e30
CPU: SNB

Bug detailed description:
-------------------------
when use mplayer to play an MPEG2 HD file and resize it, it will cause GPU hang. Following is the backtrace and dmesg.

Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [vaapi] 1920x1080 => 1920x1080 MPEG-2 VA-API Acceleration
[VD_FFMPEG] XVMC-accelerated MPEG-2.
[mi] EQ overflowing. The server is probably stuck in an infinite loop.

Backtrace:
0: X (xorg_backtrace+0x3b) [0x80a58eb]
1: X (mieqEnqueue+0x1ab) [0x80d687b]
2: X (xf86PostMotionEventP+0xd2) [0x80ba352]
3: /opt/X11R7/lib/xorg/modules/input/evdev_drv.so (0xb71f9000+0x431d) [0xb71fd31d]
4: /opt/X11R7/lib/xorg/modules/input/evdev_drv.so (0xb71f9000+0x45b8) [0xb71fd5b8]
5: X (0x8048000+0x6edbf) [0x80b6dbf]
6: X (0x8048000+0x10de84) [0x8155e84]
7: (vdso) (__kernel_sigreturn+0x0) [0xb7773400]
8: /opt/X11R7/lib/libdrm_intel.so.1 (0xb75d6000+0x6181) [0xb75dc181]
9: /opt/X11R7/lib/libdrm_intel.so.1 (drm_intel_bo_subdata+0x1d) [0xb75d7511]
10: /opt/X11R7/lib/xorg/modules/drivers/intel_drv.so (0xb75e1000+0x7074) [0xb75e8074]
11: /opt/X11R7/lib/xorg/modules/drivers/intel_drv.so (0xb75e1000+0xde97) [0xb75eee97]
12: /opt/X11R7/lib/xorg/modules/drivers/intel_drv.so (0xb75e1000+0xb2ce) [0xb75ec2ce]
13: X (0x8048000+0xbb2bb) [0x81032bb]
14: X (0x8048000+0x9745e) [0x80df45e]
15: X (BlockHandler+0x58) [0x80867f8]
16: X (WaitForSomething+0x10c) [0x80a095c]
17: X (0x8048000+0x3da9e) [0x8085a9e]
18: X (0x8048000+0x1a30a) [0x806230a]
19: /lib/libc.so.6 (__libc_start_main+0xe6) [0x8e2cc6]
20: X (0x8048000+0x19ee1) [0x8061ee1]

dmesg
[drm:ring_add_request], gen6 bsd ring 4975
[drm:blt_ring_add_request], blt ring 4978
[drm:blt_ring_add_request], blt ring 4981
[drm:blt_ring_add_request], blt ring 4983
[drm:blt_ring_add_request], blt ring 4984
[drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU idle, missed IRQ.

Reproduce steps:
-------------------------
mplayer -vo vaapi -va vaapi -fps 25 HD.Club-Alisan.Trailer-80Mbps.mpg
then resize the video winodw
Comment 1 Hai 2010-12-28 01:36:03 UTC
For Ironlake, this issue won't happen. So it's a regression.
Comment 2 Hai 2010-12-28 02:01:59 UTC
For an mpeg2 SD file, resizing it also may cause GPU to hang
The previous stack is printed by mplayer automatically.
Following is using cat /proc/2816/stack to get the stack(2816 is the pid of mplayer)

[<f8406f20>] i915_do_wait_request+0x20d/0x335 [i915]
[<f840707d>] i915_gem_object_wait_rendering+0x35/0x3d [i915]
[<f840ac56>] i915_gem_do_execbuffer+0x861/0xb58 [i915]
[<f840b03f>] i915_gem_execbuffer2+0xf2/0x175 [i915]
[<f814b20c>] drm_ioctl+0x268/0x322 [drm]
[<c02c691e>] do_vfs_ioctl+0x4fa/0x53f
[<c02c69a4>] sys_ioctl+0x41/0x61
[<c020280c>] sysenter_do_call+0x12/0x22
[<ffffffff>] 0xffffffff
Comment 3 haihao 2010-12-28 16:54:15 UTC
Even if this issue exists, I don't think it is a regression.
Comment 4 Hai 2010-12-28 17:49:41 UTC
Yes, it's not a regression. Sorry about it.
Comment 5 haihao 2010-12-28 18:42:20 UTC
It works fine on my destop and zhenyu's mobile machines .  What is your stepping?
Comment 6 Hai 2010-12-28 18:59:32 UTC
My stepping is 6
Comment 7 Gordon Jin 2010-12-28 19:11:37 UTC
Hai: Haihao was asking for graphics revision (see lspci), not cpu stepping.
Comment 8 Hai 2010-12-28 19:22:42 UTC
The graphics revision is 08.
Comment 9 haihao 2010-12-28 23:30:07 UTC
Could you try the latest master branch?
Comment 10 Hai 2010-12-28 23:52:25 UTC
I have tried it with the latest master branch.This issue still happens. But when I use another sandybridge test machine(graphics revision is 09), this issue won't happen. So I think maybe it is a hardware issue.
Comment 11 haihao 2010-12-29 19:12:14 UTC
*** Bug 32593 has been marked as a duplicate of this bug. ***
Comment 12 haihao 2010-12-29 19:19:23 UTC
How about the result after exchanging the disks?
Comment 13 Hai 2010-12-29 21:50:55 UTC
I have used this harddisk with Sugarbay. This issue won't happen. So it can be proved as a hardware issue.
Comment 14 Hai 2010-12-29 22:02:30 UTC
or a bios issue.
Comment 15 haihao 2010-12-30 21:47:46 UTC
VAAPI works fine with Zhenyu's disk on this machine. So something should be wrong on your disk.
Comment 16 Hai 2011-01-04 22:41:30 UTC
We have reinstalled a new OS and tested it on Huron River. The issue still happens occasionally. So I reopen it and the improtance can be medium.
Comment 17 haihao 2011-01-04 23:01:33 UTC
I don't think it is related to OS. it is better to build all components on this machine, not just copy from your build machine.
Comment 18 haihao 2011-01-09 18:39:58 UTC
I can't reproduce this issue on HuronRiver (the revision is also 8). Could you detail how to reproduce this issue? BTW, please attach your xorg.0.log.
Comment 19 Hai 2011-01-10 22:19:33 UTC
Created attachment 41867 [details]
Xorg.0.log
Comment 20 Hai 2011-01-10 22:23:09 UTC
Reproduce steps:
-------------------------
mplayer -vo vaapi -va vaapi -fps 25 TS1080i25_h264cab_10mbs_sally-0xe0.264  
then press "f" to switch to full screen frequently.
Comment 21 haihao 2011-01-11 00:10:33 UTC
(In reply to comment #20)
> Reproduce steps:
> -------------------------
> mplayer -vo vaapi -va vaapi -fps 25 TS1080i25_h264cab_10mbs_sally-0xe0.264  

Are you sure this is a MPEG2 issue?
Comment 22 Hai 2011-01-11 01:11:47 UTC
both of TS1080i25_h264cab_10mbs_sally-0xe0.264 and HD.Club-Alisan.Trailer-80Mbps.mpg have the same issue.
Comment 23 haihao 2011-03-14 19:56:20 UTC
Can you reproduce this issue now ?
Comment 24 Hai 2011-03-22 01:58:54 UTC
This issue won't happen with fillowing commit
Libdrm:		(master)2.4.24-6-g3b04c73650b5e9bbcb602fdb8cea0b16ad82d0c0
Mesa:		(7.10)d525a1b4686cf81eeab79c2fda78e756394d8e47
Xserver:		(master)xorg-server-1.10.0
Xf86_video_intel:		(master)2.14.901-4-gee740778f5d5355c04f6fc4564f598993b106d62
Cairo:		(master)90156f6ab7b94e9e576e34f6a2d8cb809242f8d0
Libva:		(master)b7ff2141aeb2adbf5743fed7910a62d971c15013
Kernel:	(drm-intel-fixes) 467cffba85791cdfce38c124d75bd578f4bb8625

It also won't hallpen with unstable commit
Libdrm:		(master)2.4.24-6-g3b04c73650b5e9bbcb602fdb8cea0b16ad82d0c0
Mesa:		(master)9b13c988acbf56018c52724e902a15c92ad89db3
Xserver:		(master)xorg-server-1.10.0-120-gefcb7275ce5de651f91ba4ff8bb227dfb68bb154
Xf86_video_intel:		(master)2.14.901-15-g6bd635b6c46cfa704892f640ac40db133f6fc164
Cairo:		(master)90156f6ab7b94e9e576e34f6a2d8cb809242f8d0
Libva:		(master)b7ff2141aeb2adbf5743fed7910a62d971c15013
Kernel:	(drm-intel-next) 47ae63e0c2e5fdb582d471dc906eb29be94c732f

So may close it.
Comment 25 haihao 2011-03-22 18:19:26 UTC
marked as fixed. Thanks