Bug 32731 - Prevent pointer from going outside screens in a multiscreen environment.
Prevent pointer from going outside screens in a multiscreen environment.
Status: RESOLVED DUPLICATE of bug 28893
Product: xorg
Classification: Unclassified
Component: App/xrandr
All All
: medium enhancement
Assigned To: Keith Packard
Depends on:
  Show dependency treegraph
Reported: 2010-12-29 12:53 UTC by jck
Modified: 2011-03-09 05:06 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Note You need to log in before you can comment on or make changes to this bug.
Description jck 2010-12-29 12:53:38 UTC
For example:

When I use my eeepc together with an external screen, I can configure them nicely using the gnome display preferences. However, when I want to use both screens together, It can happen that the mouse gets lost out of both screens!

The problem seems to be the different sizes of the screens (800x480 and 1440x900), the screens look like this:

          |                           |
   X      |                           |
          |                           |
--------- |                           |
|         |                           |
|         |                           |
Now this works well, if I'm within the two screens. Also, I can not move windows outside of the screens. But when I'm on the left (small) screen with the menu on top, and I want to click one of the menus and go to the top with my mouse, the mouse just disappears and does not stop at the bottom of the screen. That means, I can move my mouse in the area where the 'X' is, because when I go right, the mouse appears on this height on the larger screen.

Maybe X should not let the pointer move outside the boundaries of screens?
Comment 1 chrysn 2011-03-09 05:06:48 UTC
merging to the older bug #28893 which is about the same issue

*** This bug has been marked as a duplicate of bug 28893 ***