Bug 32845 - Sandybridge: Line rendering (buffer length/offset?) issues, including crashes
Sandybridge: Line rendering (buffer length/offset?) issues, including crashes
Status: RESOLVED DUPLICATE of bug 29172
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
7.10
x86 (IA32) All
: medium critical
Assigned To: Zou Nan hai
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-01-05 03:32 UTC by Matthias Hopf
Modified: 2011-03-09 14:51 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Screenshot of the "klein" screensaver (46.38 KB, image/png)
2011-01-05 03:34 UTC, Matthias Hopf
Details
GL_LINE_LOOP test case (2.12 KB, text/plain)
2011-01-11 10:02 UTC, Matthias Hopf
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matthias Hopf 2011-01-05 03:32:58 UTC
The xscreensaver "klein" shows some rendering artifacts in line mode, which let me assume that there are some buffer length / offset / number of primitives issues with OpenGL lines. Please note the attached screenshot.

Using this screen saver we get GPU freezes during S3 stress tests, after approx. 20-500 S3 cycles. When using multiple OpenGL apps at the same time, this tends to be reproducible earlier. I assume this is related to the rendering issue (out-of-buffer accesses), but cannot be sure.

In one case we had an obvious GPU freeze (xterm didn't output anything any more, also the desktop), but the "klein" screensaver was still running, overnight! It only froze when I tried to start up another xterm for viewing logs on the next morning... This was one of the more obscure freezes I had in my live...

System setup:
drm of 2.6.37rc7
libdrm 2.4.23
xf86-video-intel pre-2.14 git 1ac2e04
Mesa pre-7.10 git 4e8f123
Comment 1 Matthias Hopf 2011-01-05 03:34:56 UTC
Created attachment 41662 [details]
Screenshot of the "klein" screensaver
Comment 2 Wang Zhenyu 2011-01-06 00:59:22 UTC
'klein' has many subcases, what specific options you use in rendering failure case?
Comment 3 Matthias Hopf 2011-01-11 10:00:54 UTC
All pure line rendering subsystems are affected.

I created a test case, attaching it here. GL_LINE_LOOP with >=3000 line segments shows this bug.
Comment 4 Matthias Hopf 2011-01-11 10:02:32 UTC
Created attachment 41882 [details]
GL_LINE_LOOP test case

Running this test case should display a (slightly flashing) circle, and nothing else.
Comment 5 Matthias Hopf 2011-01-17 06:41:16 UTC
The freeze might actually be related to

  https://bugs.freedesktop.org//show_bug.cgi?id=32845

but doesn't have to.
Comment 6 Matthias Hopf 2011-01-17 06:53:17 UTC
(In reply to comment #5)
> The freeze might actually be related to

F*ck.
I meant

  https://bugzilla.kernel.org/show_bug.cgi?id=26932
Comment 7 Matthias Hopf 2011-02-16 09:06:50 UTC
Ping.

Any news on this? Has anybody verified that the test case shows the same issue for them?
Comment 8 Matthew Hungerford 2011-03-09 14:51:38 UTC
I had the exact same issue with sandybridge using gl_line/line_loop_line_strip.
I was able to recreate it just drawing large hallow circles.

It was fixed in Bug 29172
bugs.freedesktop.org/show_bug.cgi?id=29172

*** This bug has been marked as a duplicate of bug 29172 ***