Bug 32918 - gnome-shell / mutter crashing.
Summary: gnome-shell / mutter crashing.
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/R600 (show other bugs)
Version: git
Hardware: Other All
: medium minor
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-08 09:23 UTC by Lee Wilson
Modified: 2011-03-07 11:53 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf (184 bytes, application/octet-stream)
2011-01-08 23:16 UTC, Lee Wilson
Details
Xorg Log (36.58 KB, text/x-log)
2011-01-08 23:17 UTC, Lee Wilson
Details
dmesg (62.40 KB, text/x-log)
2011-01-08 23:18 UTC, Lee Wilson
Details
gdb output when producing the bug (11.74 KB, text/plain)
2011-02-13 11:23 UTC, Julien Durillon
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lee Wilson 2011-01-08 09:23:27 UTC
I was having problems with gnome-shell / mutter and reported it to them, they are claiming its a driver bug, so I build the latest radeon driver (following guide here - http://www.x.org/wiki/radeonBuildHowTo but am still experiencing the crashing.

I dont know where the bug lies, but as I reported it there I am doing so here too.



(gnome bug report) - https://bugzilla.gnome.org/show_bug.cgi?id=639005
Comment 1 Alex Deucher 2011-01-08 13:51:02 UTC
Please attach your xorg log and dmesg output.
Comment 2 Lee Wilson 2011-01-08 23:16:40 UTC
Created attachment 41783 [details]
xorg.conf
Comment 3 Lee Wilson 2011-01-08 23:17:02 UTC
Created attachment 41784 [details]
Xorg Log
Comment 4 Lee Wilson 2011-01-08 23:18:19 UTC
Created attachment 41785 [details]
dmesg
Comment 5 Kevin DeKorte 2011-01-10 09:59:57 UTC
Lee,

What version of clutter do you have installed?
Comment 6 Lee Wilson 2011-01-10 10:03:40 UTC
The version that builds with gnome-shell from source ( http://live.gnome.org/GnomeShell )

I build gnome-shell from that, I tend to test it daily to see if the issue has gone, so its whatever version they had at around 7am GMT
Comment 7 Lee Wilson 2011-01-11 10:12:53 UTC
I just checked it and yeah, its clutter built from git




** Checking out clutter *** [13/33]
git clone git://git.clutter-project.org/clutter
Initialized
Comment 8 Julien Durillon 2011-02-13 11:23:56 UTC
Created attachment 43323 [details]
gdb output when producing the bug

I experienced the same problem, and I ran gnome-shell through gdb. So Here is the debug output (fortunately, I even have the lines).

Hoping this helps,

Julien Durillon
Comment 9 Julien Durillon 2011-02-16 09:46:36 UTC
There is no more crash since I built the last ati driver (in the 2.6.38-rc5 kernel).

So, test with the last driver!
Comment 10 Lee Wilson 2011-02-17 00:39:05 UTC
Nice find with the new kernel, its running without crashing now, but it runs like a dog for me :(

But either way, its not crashing just got to figure out why its so slow now,
Comment 11 Jerome Glisse 2011-03-07 11:53:38 UTC
Closing as it looks like it works now, f15 is working reasonably fast for me on low end hw, maybe somethings in the stack is different.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.