When doing the log-manager refactoring to make the API generic and not text-centric, I renamed GetRecentMessages to GetRecentEvents and added a FIXME note to reconsider the return type to something better.
We should think if that's fine or not, having in mind that when we add more TplEvent* in the future they should fit in GetRecentEvents' return type.
As this is completly unused, I would be in favor of removing it as long with search_in_identifier, work in:
http://git.collabora.co.uk/?p=user/nicolas/telepathy-logger.git;a=shortlog;h=refs/heads/remove-unused (the two last)
I love removing code.