Bug 33042 - RV770: Broken Mipmap creation/display
Summary: RV770: Broken Mipmap creation/display
Status: RESOLVED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-12 17:23 UTC by Andreas Bombe
Modified: 2011-03-08 09:55 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Celestia screenshot (117.08 KB, image/png)
2011-01-12 17:23 UTC, Andreas Bombe
no flags Details
Xorg log (55.66 KB, text/plain)
2011-01-12 17:25 UTC, Andreas Bombe
no flags Details
DRM specific lines from kernel log (3.62 KB, text/plain)
2011-01-12 17:29 UTC, Andreas Bombe
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andreas Bombe 2011-01-12 17:23:50 UTC
Created attachment 41946 [details]
Celestia screenshot

I'm using mainline Linux kernels, and this bug is a regression from 2.6.36. It got broken already in 37-rc series but I haven't noticed it (compiz desktop works fine) and didn't get around to report it in time.

The latest kernel I've tested is 2.6.37-05292-g7bc4a4c running Debian sid.

It appears that the vertical size assumed during display of the mipmap is twice the mipmap's height. See attached screenshot from Celestia which shows the first level mipmap on the central star. Horizontal size seems to be correct.

Zooming outward reveals further mipmap levels with unrelated data as can be seen on the other two stars in the image.
Comment 1 Andreas Bombe 2011-01-12 17:25:52 UTC
Created attachment 41947 [details]
Xorg log
Comment 2 Andreas Bombe 2011-01-12 17:29:44 UTC
Created attachment 41948 [details]
DRM specific lines from kernel log
Comment 3 Alex Deucher 2011-01-12 18:59:27 UTC
What version of mesa are you using?  Does mesa 7.10 or 7.9.1 work any better?
Comment 4 Jerome Glisse 2011-03-08 09:55:47 UTC
Works here with r600g, reopen if you have same issue with r600g


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.