Bug 33142 - r300g produces black textures in nexuiz with glsl offsetmapping on
Summary: r300g produces black textures in nexuiz with glsl offsetmapping on
Status: RESOLVED INVALID
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r300 (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-15 00:17 UTC by Jan Kreuzer
Modified: 2011-01-18 14:44 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Kreuzer 2011-01-15 00:17:32 UTC
When i run stock phoronix test suite nexuiz i get black textures. I found that this is caused by using th effects-high.cfg. when i swith to effects-normal all textures look as they should. i found that this is caused by glsl_offsetmapping set to 1 (aka enabled). when i change it to 0 everything is okay, when i change it to 1 all textures are black. System is an rv410 (x700 mobility), latest mesa / drm / kernel from git as of today. i filed this bug against  drm, if it is more likely a mesa problem feel free to reassign it. if you need more info please tell me. thank you for your time.

greetings jan kreuzer
Comment 1 Marek Olšák 2011-01-15 02:42:00 UTC
I believe it's the issue with texture indirections we had before. The conclusion was that it's a hardware limitation that we can't overcome. I don't remember the exact details but I'll wait for Tom if he has anything to say.
Comment 2 Tom Stellard 2011-01-18 14:44:47 UTC
This is the same as bug 31013.  When offsetmapping is turned on, it creates too many texture indirections, which your hardware can't handle.  If you look in the test logs from Phoronix Test Suite, you should see an error message like this: "Too many texture indirections"


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.