Bug 33171 - [RADEON:KMS:R600G:WINE] kernel crash when loading level in FEAR
Summary: [RADEON:KMS:R600G:WINE] kernel crash when loading level in FEAR
Status: RESOLVED FIXED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: DRI git
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-15 14:54 UTC by Tobias Jakobi
Modified: 2011-07-03 06:06 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
kernel log (5.60 KB, text/plain)
2011-01-15 14:54 UTC, Tobias Jakobi
no flags Details
this GPU reset happens before the actual crash (3.66 KB, text/plain)
2011-01-15 14:55 UTC, Tobias Jakobi
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tobias Jakobi 2011-01-15 14:54:40 UTC
Created attachment 42087 [details]
kernel log

Hello!

I just triggered a kernel crash while trying out some game in wine (the same as in bug #33066).

Jan 15 23:17:22 voodoomaster kernel: BUG: unable to handle kernel paging request at ffffc90010280000

When loading the intro sequence in FEAR the screen suddenly went blank and switched back to console to display this error. The full error is attached as textfile.

Could still log into the machine via ssh and salvage the kernel log.

System:
ATI Technologies Inc Radeon HD 4770 [RV740]

drm-radeon-testing kernel
libdrm, mesa and xf86-video-ati are all git master
xorg-server-1.9.3.901

wine is version 1.3.11 and the game I triggered this with is the FEAR demo:
http://www.gamershell.com/download_10167.shtml

GLSL was enabled in wine.

Greets,
Tobias
Comment 1 Tobias Jakobi 2011-01-15 14:55:32 UTC
Created attachment 42088 [details]
this GPU reset happens before the actual crash
Comment 2 Jerome Glisse 2011-03-08 10:07:34 UTC
Does it works any better now ?
Comment 3 Tobias Jakobi 2011-03-08 12:22:30 UTC
No, not really. But I'd like to add that the GPU resets (which eventually lead to a complete crash) only appear when using DX9 level shaders. With DX8 level shader (you can select this ingame) it works kinda good.
Comment 4 Tobias Jakobi 2011-03-08 13:14:15 UTC
HL2 engine based games also seem to be particularly good in triggering a kernel crash, at least when a DX9 render path is selected.

E.g. I have HL2 (vanilla) running here with mat_dxlevel 81 (this is a DX8 renderpath with some additional eyecandy -- see http://developer.valvesoftware.com/wiki/DirectX_Versions for more information) and all gfx settings ramped up. This works kinda good (lots of lighting errors) and more importantly: I doesn't trigger any GPU resets or crashes.

However once I select a 9x dxlevel, the GPU resets start and my system doesn't survive more than 10 seconds.
Comment 5 Tobias Jakobi 2011-05-06 17:27:34 UTC
Still happens with mesa git master (6bb230970cb2da5e3fe9bc63991b4b5f92445e92) and DX level 9 shaders.
Comment 6 Tobias Jakobi 2011-07-03 06:06:03 UTC
I'm setting this one to FIXED, since I can no longer reliably reproduce the crashes with either FEAR nor the HL2 engine in DX9 shader mode.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.