Bug 33255 - [RADEON:R300C] crash using webgl (firefox 4b9)
Summary: [RADEON:R300C] crash using webgl (firefox 4b9)
Status: RESOLVED WONTFIX
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/r300 (show other bugs)
Version: 7.9
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-18 13:05 UTC by 0enjolras0
Modified: 2012-08-08 17:05 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Intresting parts from Dmesg (3.62 KB, text/plain)
2011-01-19 09:17 UTC, 0enjolras0
Details
Log Xorg (31.69 KB, text/plain)
2011-01-19 09:18 UTC, 0enjolras0
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 0enjolras0 2011-01-18 13:05:13 UTC
hy,

I get this error :

 *********************************WARN_ONCE*********************************
File r300_state.c function r300SetupRSUnit line 1521
Don't know how to satisfy InputsRead=0x00004000
***************************************************************************

trying  MOZ_GLX_IGNORE_BLACKLIST=1 firefox -P -no-remote on gentoo.
setting layers.accelerate-all true in about:config

* firefox : Mozilla Firefox 4.0b9 Mozilla i386 build for linux.

* OpenGL vendor string: X.Org R300 Project
  OpenGL renderer string: Gallium 0.4 on RS690

* kernel 2.6.36 vanilla.

regards.
Comment 1 Marek Olšák 2011-01-19 08:43:09 UTC
(In reply to comment #0)
>  *********************************WARN_ONCE*********************************
> File r300_state.c function r300SetupRSUnit line 1521
> Don't know how to satisfy InputsRead=0x00004000
> ***************************************************************************

This message is from the classic driver. Are you sure you're really running the Gallium one?
Comment 2 0enjolras0 2011-01-19 09:17:56 UTC
Created attachment 42200 [details]
Intresting parts from Dmesg
Comment 3 0enjolras0 2011-01-19 09:18:45 UTC
Created attachment 42201 [details]
Log Xorg
Comment 4 0enjolras0 2011-01-19 09:20:55 UTC
Hy 
I think i do, because i can see this in glxinfo :
  OpenGL vendor string: X.Org R300 Project
  OpenGL renderer string: Gallium 0.4 on RS690
But i apologize I can't do better.
Comment 5 Jerome Glisse 2011-03-08 10:30:02 UTC
Your firefox is not using the gallium driver, might be 32/64bits lib issue or some old copy laying around, please triple check your installation

R300C is no longer supported
Comment 6 Andreas Boll 2012-08-08 17:05:29 UTC
(In reply to comment #5)
> Your firefox is not using the gallium driver, might be 32/64bits lib issue or
> some old copy laying around, please triple check your installation
> 
> R300C is no longer supported

As mentioned above r300c wont be fixed.
Please use the r300g gallium driver.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.