Bug 33272 - Kernel DRM/Radeon KMS BSOD on HD6850-NI
Summary: Kernel DRM/Radeon KMS BSOD on HD6850-NI
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Alex Deucher
QA Contact:
Depends on:
Reported: 2011-01-19 07:36 UTC by Erdem U. Altınyurt
Modified: 2011-01-21 07:33 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

dmesg of HD3300+HD6850 (4.73 KB, patch)
2011-01-20 07:45 UTC, Erdem U. Altınyurt
no flags Details | Splinter Review
possible fix (1.58 KB, patch)
2011-01-20 13:59 UTC, Alex Deucher
no flags Details | Splinter Review

Description Erdem U. Altınyurt 2011-01-19 07:36:25 UTC
Using 2.6.38-rc1 vanilla,
When I try to load radeon kernel module with

modprobe radeon modeset=1

I got BSOD, computer doesn't give any response to me. CTRL+ALT+DEL don't working nor my main computer switch. 

modprobe radeon modeset=0

doesn't make such problem and computer looks working. But my Northern Islands (HD6850) card doesn't support Gallium3D without KMS.

Comment 1 Alex Deucher 2011-01-19 07:42:20 UTC
Have you installed the necessary ucode for your card?
Comment 2 Erdem U. Altınyurt 2011-01-19 12:25:42 UTC
definitely, right to /lib/modules/radeon directory.
Comment 3 Alex Deucher 2011-01-19 12:56:08 UTC
If you are using an initrd make sure the ucode is built into the initrd.
Comment 4 Erdem U. Altınyurt 2011-01-19 15:31:09 UTC
I don't create initrd by hand. Used make install to install code and initrd doesn't have any radeon modules.So initrd doesn't have ucode. But I thought that is just for boot with radeon module loading. I don't use that feature. 

AFAIK Since I do not load radeon module on bootup, It's doesn't necessary to have those files in initrd and load from /lib/firmware/radeon/ directly.

Does it requirement that having ucodes in initrd for running NI class cards? My internal 790GX GPU could woth with KMS without any ucode and modules in initrd. (At least with 2.6.37, I don't test it with 2.6.38-rc1 and 790GX disabled from bios since HD6850 plugged in).
Comment 5 Erdem U. Altınyurt 2011-01-19 16:09:56 UTC
Now tested my old 790GX and it's working with my setup but NI.

files from /lib/firmware/radeon. I expect that will make radeon.ko cannot found required ucodes and will not activate KMS and loaded as modeset=0. AFAIK That happens when I don't put required ucodes to fw directort with my 790GX when initial r600 support comes... 

So, when I try to load radeon without those ucodes on firmware directoy, result is same. BSOD. That make me thinking if it's not related with ucodes...
Comment 6 Alex Deucher 2011-01-19 16:24:55 UTC
The ucode is required for all asics when the radeon drm is loaded.  Most likley your initrd already has the ucode for older asics.
Comment 7 Erdem U. Altınyurt 2011-01-20 07:28:29 UTC
radeon module loaded and work as intended.
I use
"modprobe radeon pcie_gen2=1"
and it works
Weird thing is that I enabled GEN1 on my MB bios.
Mesa gives segmentation fault but could use KMS properly now.

Sorry for disturbing.
Comment 8 Erdem U. Altınyurt 2011-01-20 07:45:35 UTC
Created attachment 42226 [details] [review]
dmesg of HD3300+HD6850

Previous comment is wrong. Bug is not solved but I just enabled 790GX from bios with surround view....

So bug is not solved with that flag. "modprobe radeon" working now because of 790GX internal GPU.

I attach the kernel messages. Might be useful to understand problem. KMS looks loaded...
Comment 10 Erdem U. Altınyurt 2011-01-20 13:19:08 UTC
Yes it fixed the problem. :)
Now loads KMS thanks.

Also I noticed a failure on module load.

[drm] ib test succeeded in 0 usecs
failed to evaluate ATIF got AE_BAD_PARAMETER
[drm] Radeon Display Connectors
[drm] Connector 0:

I wish its not important.
Comment 11 Alex Deucher 2011-01-20 13:59:05 UTC
Created attachment 42240 [details] [review]
possible fix

Can you try this patch instead of the revert?
Comment 12 Erdem U. Altınyurt 2011-01-20 15:08:59 UTC
Yes, that patch fixed the issue too.

Any hint on that kernel line while loading radeon?

failed to evaluate ATIF got AE_BAD_PARAMETER

Comment 13 Alex Deucher 2011-01-21 07:33:10 UTC
(In reply to comment #12)
> Yes, that patch fixed the issue too.
> Any hint on that kernel line while loading radeon?
> failed to evaluate ATIF got AE_BAD_PARAMETER

You can ignore that.  It's an acpi method that's required on some laptops, but not on others or on desktop cards.  It's harmless.  I thought we had gotten rid of that message, but it seems to be back.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.