Bug 33348 - [r300g] Display corruption (artifacts) when using 3D graphics...
Summary: [r300g] Display corruption (artifacts) when using 3D graphics...
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r300 (show other bugs)
Version: 7.10
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-21 11:24 UTC by Dawit Alemayehu
Modified: 2011-08-06 12:19 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
glewinfo output (178.57 KB, text/plain)
2011-02-06 11:28 UTC, Dawit Alemayehu
Details
visualinfo output (17.49 KB, text/plain)
2011-02-06 11:28 UTC, Dawit Alemayehu
Details
kernel drm dmesg output (1.43 KB, text/plain)
2011-02-06 11:29 UTC, Dawit Alemayehu
Details
lspci -vv output (2.65 KB, text/plain)
2011-02-06 11:29 UTC, Dawit Alemayehu
Details
Xorg log file (34.00 KB, text/plain)
2011-02-06 11:31 UTC, Dawit Alemayehu
Details
screenshot after activating kwin desktop effects... (306.33 KB, image/jpeg)
2011-02-06 11:32 UTC, Dawit Alemayehu
Details
screenshot of asteroids3D game w/o kwin desktop effects (203.36 KB, image/png)
2011-02-06 11:34 UTC, Dawit Alemayehu
Details
screenshot of activating compositing in kwin II (272.03 KB, image/png)
2011-02-24 08:35 UTC, Dawit Alemayehu
Details
xvinfo output (2.15 KB, text/plain)
2011-02-24 12:13 UTC, Dawit Alemayehu
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dawit Alemayehu 2011-01-21 11:24:18 UTC
This bug report is the same as the one I opened downstream against KWin. See

https://bugs.kde.org/show_bug.cgi?id=262824

That bug report contains all the information about my setup. The only thing I wanted to add was the software I have on my system, an ArchLinux box:

ati-dri 7.9.0.git20101207-2
dri2proto 2.3-1
kernel26 2.6.36.3-1
libdrm 2.4.22-3
libgl 7.9.0.git20101207-2
mesa 7.9.0.git20101207-2
xf86-video-ati 6.13.2-2
xf86driproto 2.1.1-1
xorg-server 1.9.2-2
xorg-server-common 1.9.2-2
xorg-server-devel 1.9.2-2

I also tested the newer versions of the above packages with the same result:

ati-dri 7.10-1
dri2proto 2.3-1
kernel26 2.6.37-1
libdrm 2.4.23-1
libgl 7.10-1
mesa 7.10-1
xf86-video-ati 6.13.2-2
xf86driproto 2.1.1-1
xorg-server 1.9.3.901-1
xorg-server-common 1.9.3.901-1
xorg-server-devel 1.9.3.901-1
Comment 1 Dawit Alemayehu 2011-02-06 11:28:10 UTC
Created attachment 42999 [details]
glewinfo output
Comment 2 Dawit Alemayehu 2011-02-06 11:28:41 UTC
Created attachment 43000 [details]
visualinfo output
Comment 3 Dawit Alemayehu 2011-02-06 11:29:24 UTC
Created attachment 43002 [details]
kernel drm dmesg output
Comment 4 Dawit Alemayehu 2011-02-06 11:29:54 UTC
Created attachment 43004 [details]
lspci -vv output
Comment 5 Dawit Alemayehu 2011-02-06 11:31:26 UTC
Created attachment 43005 [details]
Xorg log file
Comment 6 Dawit Alemayehu 2011-02-06 11:32:18 UTC
Created attachment 43006 [details]
screenshot after activating kwin desktop effects...
Comment 7 Dawit Alemayehu 2011-02-06 11:34:06 UTC
Created attachment 43007 [details]
screenshot of asteroids3D game w/o kwin desktop effects
Comment 8 Dawit Alemayehu 2011-02-06 11:39:52 UTC
Machine Info
==========
2.6.37-ARCH #1 SMP PREEMPT Sat Jan 29 20:00:33 CET 2011 x86_64 Intel(R) Pentium(R) D CPU 3.20GHz GenuineIntel GNU/Linux

Packages installed 
==============
kernel26 2.6.37-5

ati-dri 7.10-1
dri2proto 2.3-1
freeglut 2.6.0-1
glproto 1.4.12-1
libgl 7.10-1
mesa 7.10-1
xf86driproto 2.1.1-1
xf86-video-ati 6.14.0-1
xorg-xdriinfo 1.0.4-1
xorg-server 1.9.4-1
xorg-server-common 1.9.4-1
xorg-server-devel 1.9.4-1
Comment 9 Marek Olšák 2011-02-10 18:22:37 UTC
Does the problem go away with the Mesa master branch?
Comment 10 Dawit Alemayehu 2011-02-11 13:39:58 UTC
(In reply to comment #9)
> Does the problem go away with the Mesa master branch?

Nope. It makes no difference. The problem has actually gotten worse since I got the updated packages I listed comment #8 vs the original report. And the issue stays the same with Mesa master branch from today.

ati-dri-git 20110211-1
dri2proto-git 20110211-1
glproto-git 20110211-1
libdrm-git 20110211-1
libgl-git 20110211-1
mesa-git 20110211-1

Anyhow, attempting to enable any sort of compositing (aka desktop effects) in kwin results in a completely black window ontop which are some rectangular colored  (green/red) artifacts. The 3D game is about as usable as it was in the attached screenshot.
Comment 11 Robin Wheeler 2011-02-13 05:38:11 UTC
This shows as "tearing"? on web pages, it appears to be the gallium driver not working well with Compiz. If I disable the gallium driver in Xorg.conf the tearing stops.
Comment 12 Dawit Alemayehu 2011-02-23 23:40:31 UTC
Could the fact that the kernel drm module seems to recognize my card incorrectly as an RV380 card, X600 Radeon card, have anything to do with my issues ?

>>> [drm] initializing kernel modesetting (RV380 0x1002:0x5B60)
Comment 13 Alex Deucher 2011-02-23 23:55:28 UTC
(In reply to comment #12)
> Could the fact that the kernel drm module seems to recognize my card
> incorrectly as an RV380 card, X600 Radeon card, have anything to do with my
> issues ?
> 
> >>> [drm] initializing kernel modesetting (RV380 0x1002:0x5B60)

No, that's fine.
Comment 14 Dawit Alemayehu 2011-02-24 08:35:48 UTC
Created attachment 43757 [details]
screenshot of activating compositing in kwin II
Comment 15 Alex Deucher 2011-02-24 08:52:26 UTC
Does using Xv fix the kwin issues?  A user reported on IRC that using Xv seems to fix the GL issues he was having which implies we are missing some state in the 3D driver that the 2D driver sets.
Comment 16 Dawit Alemayehu 2011-02-24 12:13:29 UTC
Created attachment 43770 [details]
xvinfo output
Comment 17 Dawit Alemayehu 2011-02-24 12:13:43 UTC
(In reply to comment #15)
> Does using Xv fix the kwin issues?  A user reported on IRC that using Xv seems
> to fix the GL issues he was having which implies we are missing some state in
> the 3D driver that the 2D driver sets.

Well Xv is most definitely enabled on my system, but I fail to see how that helps with the kwin composting issue. Perhaps, I misunderstood your question ? I have attached the output of the xvinfo just the same. If that was what you were suggesting, then no it does not help with the kwin issues. 

On the other hand,  if you were asking whether or not changing the compositing mode in kwin from "OpenGL" to "XRender" helps then the answer would yes for the most part. Unfortunately many desktop effects won't work in that mode. Anyhow, I rather doubt that was what you wanted to know.
Comment 18 Alex Deucher 2011-02-24 12:44:21 UTC
(In reply to comment #17)
> 
> Well Xv is most definitely enabled on my system, but I fail to see how that
> helps with the kwin composting issue. Perhaps, I misunderstood your question ?
> I have attached the output of the xvinfo just the same. If that was what you
> were suggesting, then no it does not help with the kwin issues. 

Use Xv; playback a video using Xv.  Xv uses the 3D engine just like OpenGL.  If the 3D driver is not properly emitting some 3D state, but Xv is, OpenGL should work properly after you've used Xv since the missing state will now be programmed properly.  xvinfo is not enough, you actually have to render some video.
Comment 19 Dawit Alemayehu 2011-02-24 13:27:54 UTC
(In reply to comment #18)
> (In reply to comment #17)
> > 
> > Well Xv is most definitely enabled on my system, but I fail to see how that
> > helps with the kwin composting issue. Perhaps, I misunderstood your question ?
> > I have attached the output of the xvinfo just the same. If that was what you
> > were suggesting, then no it does not help with the kwin issues. 
> 
> Use Xv; playback a video using Xv.  Xv uses the 3D engine just like OpenGL.  If
> the 3D driver is not properly emitting some 3D state, but Xv is, OpenGL should
> work properly after you've used Xv since the missing state will now be
> programmed properly.  xvinfo is not enough, you actually have to render some
> video.

Okay, when I do that then there is a very minor improvement. The artifacts shown in the screen shots above are no longer there, but I still get a completely dark screen with only the mouse pointer showing...
Comment 20 Dawit Alemayehu 2011-06-17 06:47:04 UTC
Problem is still there with the following updated packages:

libgl 7.10.3-1
ati-dri 7.10.3-1
libdrm 2.4.25-1
xf86-video-ati 6.14.1-1
xorg-server-common 1.10.2-1
xorg-server-utils 7.6-2
xorg-server 1.10.2-1
xf86driproto 2.1.1-1

Is there anyway to debug such that I can try ? I do not mind getting down and dirty if it means getting this issue resolved. OpenGL support has not worked on my machine ever since the ati driver was switched to the Gallium version.
Comment 21 Robin Wheeler 2011-06-17 08:26:50 UTC
I'm on ubuntu 11.04 now and unity is unusable. If I boot straight to it but on my dual boot system if I boot windows xp then simply restart the laptop unity works just fine except with "tearing" in web browser. So Yes you may be right some setup state is missing in the driver. But that still will not I believe fix the "tearing".
Comment 22 Alex Deucher 2011-06-17 09:41:13 UTC
Maybe you are having interrupt problems.  run:
cat /proc/interrupts
and see if you see the interrupts increasing for radeon.  You might try the following options on the kernel command line in grub:
pci=nomsi
irqpoll
Comment 23 Robin Wheeler 2011-06-17 15:35:45 UTC
Added both your options and looking at the cat command can see no difference and in fact cold boot still results in an unusable unity. A windows restart is still OK.
Comment 24 Dawit Alemayehu 2011-06-19 12:07:34 UTC
(In reply to comment #23)
> Added both your options and looking at the cat command can see no difference
> and in fact cold boot still results in an unusable unity. A windows restart is
> still OK.

I get the same display corruption with those options as well set as well. It does not matter if you set both or one at a time. For me the corruption is now better than what it was a couple of revisions back, but it is still unusable.
Comment 25 Dawit Alemayehu 2011-08-06 12:19:07 UTC
Seems to be finally fixed in Mesa 7.11. Dunno what the cause was, but it works fine for me on the hardware and driver I reported with the shinny new Mesa 7.11. Big thanks for whomever fixed this problem.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.