Bug 33371 - [RADEON:KMS:R600G] zsnes output all garbage when OpenGL is enabled
Summary: [RADEON:KMS:R600G] zsnes output all garbage when OpenGL is enabled
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r600 (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-22 15:02 UTC by Öyvind Saether
Modified: 2012-02-22 10:06 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Output of zsnes when OpenGL enabled (272.14 KB, image/jpeg)
2011-01-22 15:02 UTC, Öyvind Saether
Details
glxinfo (24.50 KB, text/plain)
2011-07-22 15:23 UTC, Lars Wendler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Öyvind Saether 2011-01-22 15:02:46 UTC
Created attachment 42319 [details]
Output of zsnes when OpenGL enabled

zsnes lets you choose resolution and higher resolutions require OpenGL. When enabled the window changes to the right size and the output completely becomes garbage. See screenshot.
Comment 1 Jerome Glisse 2011-03-08 10:44:32 UTC
Does it works any better with more recent mesa ? Also attach output of glxinfo
Comment 2 Pierre-Eric Pelloux-Prayer 2011-06-15 03:13:53 UTC
Works fine here using r600g + mesa 40aec11b7569fcdd2d884629b172af3db3fbaf1d

(it looks fine too using Debian's mesa : "Mesa DRI R600 (RV770 9442) 20090101  TCL DRI2")
Comment 3 Lars Wendler 2011-07-22 15:23:17 UTC
Created attachment 49439 [details]
glxinfo

Same problem here. This only happens with gallium r600 driver. As soon as I switch back to the old DRI r600 driver zsnes works as expected in opengl mode.
Comment 4 Alex Deucher 2011-07-22 15:28:50 UTC
Are you by any chance using a 32 bit version of zsnes on a 64 bit distro?
Comment 5 Lars Wendler 2011-07-22 22:59:33 UTC
(In reply to comment #4)
> Are you by any chance using a 32 bit version of zsnes on a 64 bit distro?

Yes I am. AFAIK there's no 64bit version of zsnes available. At least that's what I've read in the zsnes forums and that's how Gentoo is building the software (as 32bit app).
Comment 6 Alex Deucher 2011-07-23 08:06:23 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > Are you by any chance using a 32 bit version of zsnes on a 64 bit distro?
> 
> Yes I am. AFAIK there's no 64bit version of zsnes available. At least that's
> what I've read in the zsnes forums and that's how Gentoo is building the
> software (as 32bit app).

You need to build and install a 32bit r600g 3D driver as well.
Comment 7 Sven Arvidsson 2011-07-23 09:04:07 UTC
(In reply to comment #5)
> Yes I am. AFAIK there's no 64bit version of zsnes available. At least that's
> what I've read in the zsnes forums and that's how Gentoo is building the
> software (as 32bit app).

FWIW, it's possible to build zsnes on amd64, Debian does this.
Comment 8 Lars Wendler 2011-07-23 11:43:41 UTC
(In reply to comment #6)
> (In reply to comment #5)
> > (In reply to comment #4)
> > > Are you by any chance using a 32 bit version of zsnes on a 64 bit distro?
> > 
> > Yes I am. AFAIK there's no 64bit version of zsnes available. At least that's
> > what I've read in the zsnes forums and that's how Gentoo is building the
> > software (as 32bit app).
> 
> You need to build and install a 32bit r600g 3D driver as well.

I have both a 32bit and a 64bit r600g 3D driver installed. 
Like I said, switching from gallium r600 driver to the old mesa r600 driver fixes this problem. Although gentoo allows to have both drivers installed in parallel (and can even be switched fairly easily) I'd like to run my X with the gallium driver.

(In reply to comment #7)
> (In reply to comment #5)
> > Yes I am. AFAIK there's no 64bit version of zsnes available. At least that's
> > what I've read in the zsnes forums and that's how Gentoo is building the
> > software (as 32bit app).
> 
> FWIW, it's possible to build zsnes on amd64, Debian does this.

According to this forum post, it's not possible:

  http://board.zsnes.com/phpBB3/viewtopic.php?f=6&t=7402

But of course this might be outdated information and I could be totally wrong.
Comment 9 Michel Dänzer 2011-08-04 02:08:57 UTC
Please attach Xorg.0.log and dmesg output.
Comment 10 Michel Dänzer 2011-08-04 03:15:04 UTC
I was able to reproduce the problem, but for me it's fixed with current Mesa Git master and 7.11 branches. Make sure your 32 bit r600g is up to date, though you might also need a newer kernel / X driver.

In the worst case, turning off colour tiling might work around the problem.
Comment 11 Lars Wendler 2011-08-04 08:42:26 UTC
(In reply to comment #10)
> I was able to reproduce the problem, but for me it's fixed with current Mesa
> Git master and 7.11 branches. Make sure your 32 bit r600g is up to date, though
> you might also need a newer kernel / X driver.
> 
> In the worst case, turning off colour tiling might work around the problem.

I've just tested zsnes with gallium r600 from mesa-7.11 and the problem seems to be gone.
Comment 12 Jerome Glisse 2012-02-22 10:06:38 UTC
Closing reopen if it happens again with recent r600g.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.