Bug 33515 - System lockup with Page-flipping
Summary: System lockup with Page-flipping
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/Gallium/r300 (show other bugs)
Version: 7.10
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
: 34302 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-01-25 23:44 UTC by rockmen1
Modified: 2011-03-15 08:51 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg (45.67 KB, text/plain)
2011-02-01 04:04 UTC, rockmen1
Details
xorg.log (36.92 KB, text/plain)
2011-02-01 04:05 UTC, rockmen1
Details
xorg.log.gallium (36.92 KB, text/plain)
2011-02-01 04:05 UTC, rockmen1
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rockmen1 2011-01-25 23:44:34 UTC
Kernel: 2.6.38-RC2
MESA: 7.10 with gallium and llvm enabled.
Driver: xf86-video-ati git master
Kwin: 4.6 RC2

When desktop effects is enabled. Launch glxgears and play around desktop effects, e.g. Present Window effect. System will lock up. Can not telnet to the machines anymore.

Drm debug log only collected a bunch of garbage characters at the time when system locked up.
Comment 1 Michel Dänzer 2011-01-26 01:27:48 UTC
(In reply to comment #1)
> MESA: 7.10 with gallium and llvm enabled.

Does it also happen with the classic driver?

What card is it? (Maybe attach Xorg.0.log and dmesg)


> Drm debug log only collected a bunch of garbage characters at the time when
> system locked up.

Maybe you can get more information with netconsole.
Comment 2 rockmen1 2011-02-01 04:04:30 UTC
Created attachment 42801 [details]
dmesg
Comment 3 rockmen1 2011-02-01 04:05:03 UTC
Created attachment 42802 [details]
xorg.log
Comment 4 rockmen1 2011-02-01 04:05:50 UTC
Created attachment 42803 [details]
xorg.log.gallium
Comment 5 rockmen1 2011-02-01 04:06:08 UTC
I am using a R300 PCI-E.
Seems classic driver does not have such issue.
Comment 6 Alex Deucher 2011-02-15 09:50:47 UTC
*** Bug 34302 has been marked as a duplicate of this bug. ***
Comment 7 Marek Olšák 2011-02-22 05:46:05 UTC
Could you try latest kernel 2.6.38-rc*, latest xf86-video-ati from git, and r300g from the Mesa master branch?
Comment 8 rockmen1 2011-02-27 20:22:22 UTC
(In reply to comment #7)
> Could you try latest kernel 2.6.38-rc*, latest xf86-video-ati from git, and
> r300g from the Mesa master branch?

still the same
Comment 9 Marek Olšák 2011-02-28 03:23:13 UTC
Does disabling page flipping help?
Comment 10 gabgav 2011-02-28 07:12:38 UTC
Kernel: 2.6.36 and 2.6.38-RC4
MESA: 7.10 with gallium and llvm enabled.
Driver: xf86-video-ati 6.14.0
WM: Kwin 4.6.0 and TWM
Card: Radeon Mobility X300

I have the same problem with the hardware listed above (Bug 34302). Disabling page-flipping does not help.
Comment 11 Marek Olšák 2011-03-12 14:25:53 UTC
Does this kernel patch help?

https://bugs.freedesktop.org/attachment.cgi?id=44345
Comment 12 rockmen1 2011-03-15 08:22:42 UTC
Seems the patch works!
Comment 13 Marek Olšák 2011-03-15 08:51:30 UTC
Closing because the patch is now part of kernel 2.6.38.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.