Bug 33681 - Random system lockup with KMS, Mobility Radeon HD3470
Summary: Random system lockup with KMS, Mobility Radeon HD3470
Status: RESOLVED MOVED
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: XOrg git
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-29 02:18 UTC by Jaime Velasco Juan
Modified: 2019-11-19 08:17 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
kernel log (458.48 KB, text/plain)
2011-01-29 02:18 UTC, Jaime Velasco Juan
no flags Details
another kernel log (470.98 KB, text/plain)
2011-01-29 02:19 UTC, Jaime Velasco Juan
no flags Details
another kernel log (474.99 KB, text/plain)
2011-01-29 02:19 UTC, Jaime Velasco Juan
no flags Details
X log (37.16 KB, text/plain)
2011-01-29 02:20 UTC, Jaime Velasco Juan
no flags Details
lspci (2.15 KB, text/plain)
2011-01-29 02:20 UTC, Jaime Velasco Juan
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaime Velasco Juan 2011-01-29 02:18:19 UTC
Created attachment 42685 [details]
kernel log

The computer often locks itself, the panel suddenly loses the image (it sometimes blooms, or get filled with a solid color or a pattern of vertical white and grey stripes). I don't know how to trigger the bug, it can happen anytime, even with an idle system.

It has happened to me since I started using KMS, it was stable both with radeonHD and radeon drivers in UMS mode. The frequency of the problem has varied a lot; with the first KMS versions it happened a lot, then it seemed to be fixed with some kernel versions, but reappeared with others... As the problem is random, it can happen after a few minutes of uptime, or after some hours, or not happen at all.

At first, I thougth the kernel was completely dead, but I recently found out that I can use SysRq+S and SysRq+T to get some logs. If I try to reboot with SysRq+B the system locks fully and doesn't react to anything, I always have to do a hard reboot.

I'll attach lspci, one X log and three differen kernel logs.
Comment 1 Jaime Velasco Juan 2011-01-29 02:19:03 UTC
Created attachment 42686 [details]
another kernel log
Comment 2 Jaime Velasco Juan 2011-01-29 02:19:30 UTC
Created attachment 42687 [details]
another kernel log
Comment 3 Jaime Velasco Juan 2011-01-29 02:20:07 UTC
Created attachment 42688 [details]
X log
Comment 4 Jaime Velasco Juan 2011-01-29 02:20:35 UTC
Created attachment 42689 [details]
lspci
Comment 5 Martin Peres 2019-11-19 08:17:39 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/drm/amd/issues/175.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.