Bug 33726 - Gradients rendered incorrectly
Summary: Gradients rendered incorrectly
Status: RESOLVED NOTOURBUG
Alias: None
Product: poppler
Classification: Unclassified
Component: cairo backend (show other bugs)
Version: unspecified
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: poppler-bugs
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-30 10:09 UTC by ben
Modified: 2012-11-20 10:52 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Rendered using poppler/evince (169.69 KB, image/png)
2011-01-30 10:09 UTC, ben
Details
rendered using Acrobat Reader (102.93 KB, image/png)
2011-01-30 10:10 UTC, ben
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ben 2011-01-30 10:09:22 UTC
Created attachment 42722 [details]
Rendered using poppler/evince

The gradients on this PDF do not get rendered correctly: http://emetral.web.cern.ch/emetral/USPAS09course/SpaceCharge.pdf

I am forwarding this downstream bug:https://bugs.launchpad.net/ubuntu/+source/poppler/+bug/710137
Comment 1 ben 2011-01-30 10:10:14 UTC
Created attachment 42723 [details]
rendered using Acrobat Reader
Comment 2 Albert Astals Cid 2011-01-30 14:23:12 UTC
Seems to be cairo backend specific
Comment 3 Carlos Garcia Campos 2011-02-26 04:18:19 UTC
(In reply to comment #2)
> Seems to be cairo backend specific

I can't reproduce it, I see the same output than splash, which is different than the acroread screenshot (the background color).
Comment 4 Albert Astals Cid 2011-02-26 04:44:00 UTC
I do get an empty white background with cairo and a purple-ish one (yes a bit different from Acroread it seems with splash)

Ask anything you might want me to do to help see why i get nothing in cairo.
Comment 5 Carlos Garcia Campos 2011-02-26 05:16:17 UTC
Maybe it depends on pixman/cairo versions, I'm currently using git master for both.
Comment 6 Albert Astals Cid 2011-02-26 07:04:19 UTC
I'm using 
  pixman 0.20.2
  cairo 1.10.2
that i think are the latest versions. If you are sure this is a pixmap/cairo problem and not ours you should mark the bug as resolved->notourbug
Comment 7 Carlos Garcia Campos 2011-02-26 07:07:10 UTC
No, I'm not sure.
Comment 8 Germán Poo-Caamaño 2012-11-02 23:18:19 UTC
Before building cairo 1.12, I could reproduce this bug (with a white
background)  After building poppler on cairo 1.12, the PDF looks fine
to me.

Probably an issue with an old cairo version.
Comment 9 Albert Astals Cid 2012-11-19 21:20:44 UTC
So should we close this one?
Comment 10 Adrian Johnson 2012-11-20 10:52:15 UTC
Works for me with cairo 1.12. Looks like a cairo bug that has been fixed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.