Bug 33755 - System hangs with x-testing and gtkperf tests
Summary: System hangs with x-testing and gtkperf tests
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/R100 (show other bugs)
Version: git
Hardware: x86 (IA32) All
: high major
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-01-31 05:23 UTC by KavithaReddy
Modified: 2011-04-18 01:49 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg log file (30.00 KB, text/plain)
2011-01-31 05:23 UTC, KavithaReddy
Details
glx information (14.29 KB, text/plain)
2011-01-31 05:24 UTC, KavithaReddy
Details
X configuration file (1.38 KB, text/plain)
2011-01-31 05:25 UTC, KavithaReddy
Details

Note You need to log in before you can comment on or make changes to this bug.
Description KavithaReddy 2011-01-31 05:23:41 UTC
Created attachment 42746 [details]
Xorg log file

KMS Driver Stack Details:
=========================

1)    Kernel-2.6.35-22-generic-pae   
2)    Libdrm-2.4.21
3)    Mesa-7.9-rc1
4)    Xorg-server-1.9.0
5)    ddx: xf86-video-ati-6.13.99


System Environment:
===================

O.S. - Ubuntu-10.10(32 bit)
ASIC – Juniper LE [HD5750]
CPU  - Intel(R) Core(TM) 2 CPU 6300 @1.86GHz

Steps to Reproduce:
===================
1) Connect display: DFP 
2) startx
3) Install phoronix test suite as below
   a.Down load test suite from the below location 
	http://www.phoronix-test-suite.com/releases/repo/pts.debian/files/phoronix-test-suite_2.8.2_all.deb
   b.sudo dpkg -i phoronix-test-suite_2.8.2_all.deb
   c.Install any dependency related to PHP with synaptic

4) Run X-testing application as below using phoronix-test-suite
FORCE_TIMES_TO_RUN=1  phoronix-test-suite run x-testing


Observation:  Test runs for some time and after that System gets hang. Keyboard and Mouse are not working but able to ping the system IP.

Additional Information:
-----------------------------------
-->Issue is also observed with Redwood LP
-->Issue is also observed with gtkperf test [FORCE_TIMES_TO_RUN=1 phoronix-test-suite run gtkperf]
-->Issue is not observed with Cedar Pro [Bass] ASIC
Comment 1 KavithaReddy 2011-01-31 05:24:39 UTC
Created attachment 42747 [details]
glx information
Comment 2 KavithaReddy 2011-01-31 05:25:10 UTC
Created attachment 42748 [details]
X configuration file
Comment 3 Alex Deucher 2011-01-31 07:54:04 UTC
Please make sure your kernel has this patch:
http://git.kernel.org/?p=linux/kernel/git/airlied/drm-2.6.git;a=commitdiff;h=1e644d6dce366a7bae22484f60133b61ba322911
Comment 4 KavithaReddy 2011-04-18 01:49:24 UTC
(In reply to comment #3)
> Please make sure your kernel has this patch:
> http://git.kernel.org/?p=linux/kernel/git/airlied/drm-2.6.git;a=commitdiff;h=1e644d6dce366a7bae22484f60133b61ba322911


fixed with the latest build


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.