Bug 33926 - The game Steel Storm jerky fps
Summary: The game Steel Storm jerky fps
Status: RESOLVED FIXED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965 (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium minor
Assignee: Ian Romanick
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-04 23:16 UTC by Md Imam Hossain
Modified: 2011-07-29 09:36 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Md Imam Hossain 2011-02-04 23:16:57 UTC
Mesa from git 7.11-devel has a problem with the game Steel Storm episode 1
http://www.steel-storm.com/content/ - (Free)

Jerky fps when Intel graphics is selected from graphics option menu.

case 1: dark stages like first level has less jerkiness
case 2: stages with having light have most jerkiness (unplayable)

less Jerky fps when no Intel graphics is selected from graphics option menu.

case1: same as above
case2: same as above

the game were running at perfect speed with Mesa 7.8.3-rc1 and 7.9.1.
the problem is arises probably with Mesa 7.10.

System:
Intel GMA 4500 256MB

Ubuntu 10.10
Linux 2.6.36-02063603-generic
Mesa 7.11-devel from git
Intel xf86-video-intel-2.13.0
bundled X.org from Ubuntu 10.10
Comment 1 Md Imam Hossain 2011-03-03 04:26:50 UTC
Mesa 7.10.1 is also affected by this bug
Comment 2 Md Imam Hossain 2011-06-08 07:01:08 UTC
Status update:

Problem occurs only when Intel Graphics is selected from Graphics option menu.

This is a regression since Mesa 7.9 series.

System:

Ubuntu 10.10
Linux 2.6.38-02063807-generic
libdrm 2.4.24
Xserver 1.9.3
xf86-video-intel 2.14.0
Mesa 7.11-devel mesa-ef59049c5242a1be7fa59a182d342191185dd62b

Thank you
Comment 3 Md Imam Hossain 2011-07-29 09:36:29 UTC
As of Mesa 5c9e0ad5fddf216921703a0aa9c911a51226cdfd this is fixed.

fps is smooth when Intel Graphics is selected from Graphics Option Mesa in the game.

closing bug


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.