Bug 33987 - no full color on laptop screen.
Summary: no full color on laptop screen.
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nouveau (show other bugs)
Version: unspecified
Hardware: All Linux (All)
: high normal
Assignee: Nouveau Project
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on: 34680
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-07 02:49 UTC by develop
Modified: 2011-11-09 14:50 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg.log (176.98 KB, text/plain)
2011-02-07 02:50 UTC, develop
no flags Details
lspci.log (2.31 KB, text/plain)
2011-02-07 02:51 UTC, develop
no flags Details
xorg.log (37.15 KB, text/plain)
2011-02-07 02:51 UTC, develop
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description develop 2011-02-07 02:49:54 UTC
the display show less colors (i think 16bit) on laptop screen. a display connected with LVDS show colors normal (i think 24bit).

my laptop is a Dell Latitude E6410
Comment 1 develop 2011-02-07 02:50:16 UTC
Created attachment 43024 [details]
dmesg.log
Comment 2 develop 2011-02-07 02:51:00 UTC
the bug is reproduced since Ubuntu Lucid till Kubuntu Natty
Comment 3 develop 2011-02-07 02:51:17 UTC
Created attachment 43025 [details]
lspci.log
Comment 4 develop 2011-02-07 02:51:40 UTC
Created attachment 43026 [details]
xorg.log
Comment 5 Yuriy Khomchik 2011-02-25 00:38:30 UTC
Try this: http://nouveau.freedesktop.org/wiki/Dithering.
Comment 6 develop 2011-02-25 11:17:51 UTC
yes that will works.

but i will fallback again to nvidia, nouveau is so unstable with my hardware


Screen 0: minimum 320 x 200, current 1440 x 900, maximum 8192 x 8192
eDP-1 connected 1440x900+0+0 (normal left inverted right x axis y axis) 303mm x 190mm
        EDID:
                00ffffffffffff004ca3425400000000
                00140104951e13780a63168b5b579529
                1e4f5400000001010101010101010101
                0101010101011d2aa0e8518420302e46
                99002fbe1000001a141ca0e851842030
                2e4699002fbe1000001a000000fe0043
                353144578231343142540a2000000000
                00004101190000000009010a202000f9
        dithering:      On
                supported: Off          On           Automatic   
        scaling mode:   Full
                supported: None         Full         Center       Full aspect 
   1440x900       60.0*+   40.0  
   1152x864       60.0  
   1024x768       59.9  
   800x600        59.9  
VGA-1 disconnected (normal left inverted right x axis y axis)
        scaling mode:   None
                supported: None         Full         Center       Full aspect 
DP-1 disconnected (normal left inverted right x axis y axis)
        dithering:      Off
                supported: Off          On           Automatic   
        scaling mode:   Full
                supported: None         Full         Center       Full aspect 
DP-2 disconnected (normal left inverted right x axis y axis)
        dithering:      Off
                supported: Off          On           Automatic   
        scaling mode:   Full
                supported: None         Full         Center       Full aspect
Comment 7 Ben Skeggs 2011-11-09 14:50:30 UTC
Nouveau kernel git should be able to handle this now.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.