Bug 34015 - [i945gm] GPU lockup (ESR: 0x00000001 IPEHR: 0x02000004)
Summary: [i945gm] GPU lockup (ESR: 0x00000001 IPEHR: 0x02000004)
Status: RESOLVED DUPLICATE of bug 34014
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.6 (2010.12)
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Chris Wilson
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-07 18:37 UTC by Bryce Harrington
Modified: 2011-04-12 02:30 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
BootDmesg.txt (66.61 KB, text/plain)
2011-02-07 18:38 UTC, Bryce Harrington
no flags Details
CurrentDmesg.txt (124.68 KB, text/plain)
2011-02-07 18:38 UTC, Bryce Harrington
no flags Details
i915_error_state.txt (759.70 KB, text/plain)
2011-02-07 18:40 UTC, Bryce Harrington
no flags Details
XorgLog.txt (139.17 KB, text/plain)
2011-02-07 18:41 UTC, Bryce Harrington
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bryce Harrington 2011-02-07 18:37:01 UTC
Forwarding this bug from Ubuntu reporter Antono Vasiljev:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/714554

[Problem]
GPU lockup (hangcheck timer elapsed) on i945, on the 2.6.32 kernel and -intel driver 2.14.0, following a crash of compiz.

[Original Description]
Right after login

From GPU dump:
ACTHD: 0xffffffff
EIR: 0x00000000
EMR: 0xffffffed
ESR: 0x00000001
PGTBL_ER: 0x00000000
IPEHR: 0x02000004
IPEIR: 0x00000000
INSTDONE: 0x7ffffa41
    busy: Bypass FIFO
    busy: Color calculator
    busy: Map filter

From dmesg:
[11291.029157] Valid eCryptfs headers not found in file header region or xattr region
[11291.029161] Either the lower file is not in a valid eCryptfs format, or the key could not be retrieved. Plaintext passthrough mode is not enabled; returning -EIO
[11291.255694] compiz[1827]: segfault at 7070613f ip 0066333d sp bfa16644 error 4 in libpthread-2.12.2.so[65b000+15000]
[11297.772108] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[11297.775630] [drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -11 (awaiting 1458544 at 1458541, next 1458547)
[11299.844049] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[11299.844597] [drm:i915_reset] *ERROR* Failed to reset chip.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-video-intel 2:2.14.0-1ubuntu6
ProcVersionSignature: Ubuntu 2.6.37-12.26-generic 2.6.37
Uname: Linux 2.6.37-12-generic i686
Architecture: i386
Chipset: i945gm
CompisitorRunning: None
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
DRM.card0.DVI.D.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x800
 edid-base64: AP///////wAGEF+cAAAAAAgQAQOAHRJ4Ci8wl1hTiyklUFQAAAABAQEBAQEBAQEBAQEBAQEBvBsAoFAgFzAwIDYAHrMQAAAYAAAAAQAGECAAAAAAAAAAAAogAAAA/gBMUDEzM1dYMS1UTEExAAAA/gBDb2xvciBMQ0QKICAgAMI=
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
Date: Mon Feb  7 14:48:39 2011
DistUpgraded: Yes, recently upgraded Log time: 2010-11-23 13:52:42.791339
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: vboxhost, 4.0.0: added
DumpSignature: 9f5d9022
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
GraphicsCard:
 Subsystem: Intel Corporation Device [8086:7270]
   Subsystem: Intel Corporation Device [8086:7270]
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release i386 (20101007)
InterpreterPath: /usr/bin/python2.7
MachineType: Apple Inc. MacBook2,1
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:

ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-1-generic root=UUID=ad5bb6dc-36b0-434c-a044-b8fd05021ce5 ro quiet splash vt.handoff=7
ProcKernelCmdLine_: BOOT_IMAGE=/boot/vmlinuz-2.6.37-12-generic root=UUID=ad5bb6dc-36b0-434c-a044-b8fd05021ce5 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 xserver-xorg 1:7.6~3ubuntu3
 libdrm2 2.4.23-1ubuntu3
 xserver-xorg-video-intel 2:2.14.0-1ubuntu6
Renderer: Hardware acceleration
SourcePackage: xserver-xorg-video-intel
Title: [i945gm] GPU lockup 9f5d9022
UserGroups:

dmi.bios.date: 06/27/07
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MB21.88Z.00A5.B07.0706270922
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Mac-F4208CA9
dmi.board.vendor: Apple Inc.
dmi.board.version: PVT
dmi.chassis.asset.tag: Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F4208CA9
dmi.modalias: dmi:bvnAppleInc.:bvrMB21.88Z.00A5.B07.0706270922:bd06/27/07:svnAppleInc.:pnMacBook2,1:pvr1.0:rvnAppleInc.:rnMac-F4208CA9:rvrPVT:cvnAppleInc.:ct10:cvrMac-F4208CA9:
dmi.product.name: MacBook2,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
version.compiz: compiz 1:0.9.2.1+glibmainloop4-0ubuntu9
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10-1ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati N/A
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu6
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau N/A
Comment 1 Bryce Harrington 2011-02-07 18:38:23 UTC
Created attachment 43070 [details]
BootDmesg.txt
Comment 2 Bryce Harrington 2011-02-07 18:38:58 UTC
Created attachment 43071 [details]
CurrentDmesg.txt
Comment 3 Bryce Harrington 2011-02-07 18:40:25 UTC
Created attachment 43072 [details]
i915_error_state.txt

And gpu dump is at https://bugs.launchpad.net/xserver-xorg-video-intel/+bug/714554/+attachment/1835789/+files/IntelGpuDump.txt

(You should bump up the max file size on this bugzilla so that gpu dump files can be attached to bug reports...)
Comment 4 Bryce Harrington 2011-02-07 18:41:15 UTC
Created attachment 43073 [details]
XorgLog.txt
Comment 5 Chris Wilson 2011-02-08 01:40:02 UTC

*** This bug has been marked as a duplicate of bug 34014 ***
Comment 6 Daniel Vetter 2011-04-12 02:25:31 UTC
I'm suspecting that this is actually not a dupe for two reasons:
1) bug 34014 is (besides this bug here) all about i915gm, this is a i945
2) 2.6.37 does not have relaxed fencing

Can you please forward whether the patch at https://bugs.freedesktop.org/show_bug.cgi?id=34014#c27 does indeed fix the problem of the original reporter?
Comment 7 Chris Wilson 2011-04-12 02:30:03 UTC
Daniel, you are undermining my confidence that 2.15.0 won't hang be a regression-fest! :-p


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.