Bug 34237 - External LCD monitor flickers every 30 seconds radeon mobility x1400
Summary: External LCD monitor flickers every 30 seconds radeon mobility x1400
Status: RESOLVED NOTOURBUG
Alias: None
Product: DRI
Classification: Unclassified
Component: DRM/Radeon (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-13 11:30 UTC by Jože Prijatelj
Modified: 2011-03-02 07:28 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jože Prijatelj 2011-02-13 11:30:11 UTC
OS: ArchLnux
driver: 6.14.0-1
kernel: 2.6.37-5
libdrm: 2.4.23-1
mesa: 7.10.0.git20110206-2
KMS: yes
graphic card: mobility x1400

-----------------------
To reproduce.
LCD monitor is plugged into laptop. While KDE4 is loading external monitor flickeres once. When KDE4 is already loaded external monitor flickers twice in a row with 2 seconds delay. One flick is lasting about one second. Then external lcd monitor flickers every 30 seconds. It also flickeres if I just type a command: 'xrandr'.
Comment 1 Alex Deucher 2011-02-13 13:58:53 UTC
This sounds like monitor polling on the analog port.  Disable it by booting with
drm_kms_helper.poll=0 on your kernel command line in grub.  Also make sure kde is not polling the monitors itself in the background at regular intervals.
Comment 2 comio 2011-02-14 08:20:47 UTC
(In reply to comment #1)
> This sounds like monitor polling on the analog port.  Disable it by booting
> with
> drm_kms_helper.poll=0 on your kernel command line in grub.  Also make sure kde
> is not polling the monitors itself in the background at regular intervals.

OK I have the same issue. I surely disable the polling in kms... but I don't know where I can disable the monitor polling in KDE... any idea?

thanks

luigi
Comment 3 Alex Deucher 2011-02-14 08:29:08 UTC
(In reply to comment #2)
> OK I have the same issue. I surely disable the polling in kms... but I don't
> know where I can disable the monitor polling in KDE... any idea?

I'm not that familiar with kde.  I've heard knotify might do it.  You might want to ask on one of the kde mailing lists or kde bugzilla.
Comment 4 comio 2011-02-14 10:45:50 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > OK I have the same issue. I surely disable the polling in kms... but I don't
> > know where I can disable the monitor polling in KDE... any idea?
> 
> I'm not that familiar with kde.  I've heard knotify might do it.  You might
> want to ask on one of the kde mailing lists or kde bugzilla.

poll=0 doesn't solve the problem. Anyway... I think that knotify4 is the culprit.

ciao

luigi
Comment 5 comio 2011-02-14 11:00:19 UTC
My configuration is very similar to Joze:
OS: Gentoo
driver: video-ati 6.14.0
kernel: 2.6.37
libdrm: 2.4.23
mesa: 7.10
KMS: yes
graphic card: mobility x1400

PC Dell Inspiron 6400

The second screen is not usable... and I don't understand how I can disable the polling.

ciao

luigi
Comment 6 comio 2011-02-14 11:25:23 UTC
Can be related?

http://bugs.kde.org/show_bug.cgi?id=170920
Comment 7 Alex Deucher 2011-02-14 12:15:54 UTC
(In reply to comment #6)
> Can be related?
> 
> http://bugs.kde.org/show_bug.cgi?id=170920

Probably the same issue.  This is most likely a KDE issue rather than a driver issue.
Comment 8 comio 2011-02-14 12:44:42 UTC
This seems to be related (I will check asap)

https://bugzilla.kernel.org/show_bug.cgi?id=26552
Comment 9 Jože Prijatelj 2011-02-15 08:48:42 UTC
(In reply to comment #8)
> This seems to be related (I will check asap)
> 
> https://bugzilla.kernel.org/show_bug.cgi?id=26552

This is not a KDE4 related. I experience this also with xmonad, openbox, lxde...

@Comio I also have this problems as on that link you pasted: https://bugzilla.kernel.org/show_bug.cgi?id=26552 I've also uploaded a video http://www.youtube.com/watch?v=rjhAknBoJDE

Has anyone found a solution yet to one or another bug? (if they are even related) or do we have to wait for next kernel release?
Comment 10 comio 2011-02-15 08:54:25 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > This seems to be related (I will check asap)
> > 
> > https://bugzilla.kernel.org/show_bug.cgi?id=26552
> 
> This is not a KDE4 related. I experience this also with xmonad, openbox,
> lxde...
> 
> @Comio I also have this problems as on that link you pasted:
> https://bugzilla.kernel.org/show_bug.cgi?id=26552 I've also uploaded a video
> http://www.youtube.com/watch?v=rjhAknBoJDE
> 
> Has anyone found a solution yet to one or another bug? (if they are even
> related) or do we have to wait for next kernel release?


Try to use the old pll (new_pll=0 option). My problem is different: when the software probes the second screen (like xrandr -q) the external monitor shows for a second a black screen. The solution seems to disable the krandr periodical probe... but I will test in this afternoon at home.

best regards.

luigi
Comment 11 Alex Deucher 2011-02-15 09:20:54 UTC
I think there may be several different issues here: 
1. blinking when probing displays
2. unstable display all the time

If you have an unstable display all the time, please try Dave's drm-fixes kernel tree:
http://git.kernel.org/?p=linux/kernel/git/airlied/drm-2.6.git;a=shortlog;h=refs/heads/drm-fixes

If you just have display problems when probing the displays (either manually with xrandr or polling by kde) you'll need to disable the polling.
Comment 12 Jože Prijatelj 2011-02-15 09:35:40 UTC
(In reply to comment #11)
> I think there may be several different issues here: 
> 1. blinking when probing displays
> 2. unstable display all the time
> 
> If you have an unstable display all the time, please try Dave's drm-fixes
> kernel tree:
> http://git.kernel.org/?p=linux/kernel/git/airlied/drm-2.6.git;a=shortlog;h=refs/heads/drm-fixes
> 
> If you just have display problems when probing the displays (either manually
> with xrandr or polling by kde) you'll need to disable the polling.

Wow. radeon.new_pll=0 solved the every 30 seconds flickering. I have running krandr in KDE4 and it doesn't flicker.

So this bug should be marked as solved?

Now I have to try Dave's drm-fixes (Which is another bug).

Thank you comio.
Thank you Alex Deucher for that link. I'm gonna try it.
Comment 13 Alex Deucher 2011-02-15 09:45:54 UTC
(In reply to comment #12)
> 
> Wow. radeon.new_pll=0 solved the every 30 seconds flickering. I have running
> krandr in KDE4 and it doesn't flicker.
> 
> So this bug should be marked as solved?
> 
> Now I have to try Dave's drm-fixes (Which is another bug).
> 
> Thank you comio.
> Thank you Alex Deucher for that link. I'm gonna try it.

the new_pll option was removed in 2.6.37, so you probably just disabled kms.  I'd recommend drm-fixes as it contains several pll fixes that should fix your problem.
Comment 14 Thierry Vignaud 2011-03-02 01:55:46 UTC
I've tried 2.6.38-rc6-git 7 (which seems to include Dave's drm-fixes) w/o any success. I still got intermitent black screen.
For the record, my LCD is behind a KVM that corrupts EDID thus making the kernel to keep loudly complaining in dmesg
Comment 15 Alex Deucher 2011-03-02 07:28:27 UTC
(In reply to comment #14)
> I've tried 2.6.38-rc6-git 7 (which seems to include Dave's drm-fixes) w/o any
> success. I still got intermitent black screen.
> For the record, my LCD is behind a KVM that corrupts EDID thus making the
> kernel to keep loudly complaining in dmesg

It it happens it regular intervals it sounds like some sort of polling.  Have you tried drm_kms_helper.poll=0?  Also, make sure knotify or upowerd are not polling the monitors regularly.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.