Bug 34331 - cannot get a file from public@disk.jabbim.cz
Summary: cannot get a file from public@disk.jabbim.cz
Status: NEW
Alias: None
Product: Telepathy
Classification: Unclassified
Component: gabble (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Telepathy bugs list
QA Contact: Telepathy bugs list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-02-16 03:21 UTC by Matej Cepl
Modified: 2011-05-25 00:21 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Gabble log (241.03 KB, text/x-log)
2011-02-16 03:21 UTC, Matej Cepl
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Matej Cepl 2011-02-16 03:21:57 UTC
Created attachment 43424 [details]
Gabble log

When trying to get a file from my Public Jabbim Disk (see http://translate.google.com/translate?u=http%3A%2F%2Fwww.jabber.cz%2Fwiki%2FJabber_Disk&hl=en&langpair=auto|en&tbb=1&ie=UTF-8 for its description) I run

get #15

command, Empathy asks for confirmation of file transfer, but it never starts actually.

empathy-2.91.6.1-5.fc15.x86_64
telepathy-gabble-0.11.6-2.fc15.x86_64

When discussing this on #telepathy

sjoerd -> mcepl: if you need to set the proxy by hand something is very wrong
sjoerd -> mcepl: also, which client is on the other end ?
mcepl  a bot ... public@disk.jabbim.cz .. works just fine with gajim
mcepl  (and bitlbee, when it works actually )
sjoerd -> mcepl if it has a public ip it's much more likely there is an interop issue with that bot then an issue which you can workaround with your proxy server settings
sjoerd -> mcepl a gabble debug log would be a good start
mcepl ->  sjoerd: does Gabble support outband file transfers? I am not sure I understand the log, but it looks like it tried the inband FT.
sjoerd -> yes gabble supports outband file transfers
sjoerd -> but it can fallback on inband ones if those fail
mcepl -> ah, so it tried fallback.
mcepl -> BTW, using telepathy-gabble-0.11.6-2.fc15.x86_64 ... that should be recent enough, right?
mcepl -> sjoerd: <see attached log>
sjoerd -> mcepl: that was an incoming filetransfer right ?
mcepl -> yes, I asked the bot to send me a file
sjoerd -> mcepl: the bot says it can do both ibb and bytestream, with ibb preferred
mcepl -> this one http://disk.jabbim.cz/mcepl@ceplovi.cz/eclipse-GIT-import-C-project.ogv
sjoerd -> we pick ibb and then it doesn't send us anything?
mcepl -> sjoerd: let me investigate it
sjoerd -> mcepl it just sends us a message with an empty body for some reason

When asked on jabbim.cz support MUC I was told that they have received this:

<iq from='xxxx.cz/5b2ad238' id='734329' type='error'><open sid='732062' block-size='4096' xmlns='http://jabber.org/protocol/ibb'/><error code='400' type='modify'><bad-request xmlns='urn:ietfarams:xml:ns:xmpp-stanzas'/></error></iq>

and

<iq id='734329' to='xxxxx/5b2ad238' type='set' xmlns='jabber:client'><open sid='732062' block-size='4096' xmlns='http://jabber.org/protocol/ibb'/></iq>
Comment 1 Matej Cepl 2011-05-25 00:21:10 UTC
This bug is still going strong with telepathy-gabble-0.12.0-1.fc15.x86_64


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.