Bug 34417 - [Ironlake LVDS Vaio-Y] Ineffectual backlight brightness controls
[Ironlake LVDS Vaio-Y] Ineffectual backlight brightness controls
Status: RESOLVED FIXED
Product: DRI
Classification: Unclassified
Component: DRM/Intel
XOrg git
x86-64 (AMD64) Linux (All)
: medium normal
Assigned To: Chris Wilson
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-17 16:43 UTC by Michel Alexandre Salim
Modified: 2011-11-24 05:31 UTC (History)
1 user (show)

See Also:


Attachments
Xorg log (23.48 KB, text/plain)
2011-02-17 16:44 UTC, Michel Alexandre Salim
no flags Details
dmesg (122.64 KB, text/plain)
2011-02-17 16:44 UTC, Michel Alexandre Salim
no flags Details
register dumps (8.77 KB, text/plain)
2011-02-17 16:47 UTC, Michel Alexandre Salim
no flags Details
VBIOS dump (64.00 KB, application/octet-stream)
2011-02-17 16:47 UTC, Michel Alexandre Salim
no flags Details
mjg's i915 native GPU backlight control patch from linux-next (7.23 KB, patch)
2011-07-13 06:04 UTC, Michel Alexandre Salim
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Alexandre Salim 2011-02-17 16:43:17 UTC
chipset: Ironlake (Intel Core i5 U430M)
system:  x86_64

software versions:
xorg-x11-drv-intel-2.14.0-2.fc15.x86_64
xorg-x11-server-Xorg-1.9.99.1-4.20101201.fc15.x86_64
mesa-libGL-7.10-0.26.fc15.x86_64
libdrm-2.4.24-0.2.20110106.fc15.x86_64

kernel: 2.6.38-rc5+ (drm-intel-fixes 811779a0fbd23035872d1fc8f2d1baf550a94f10)
distribution: Fedora Rawhide
machine: Sony Vaio VPCY2190X (2nd-generation Y series, customized-to-order)
connector: LVDS (internal panel)

Reproducibility: always
Steps:
1. Boot to graphical mode
2. Log in
3. Try setting brightness with function keys or xbacklight

The backlight brightness controls, both GNOME (with Fn keys) and xbacklight, do not actually affect the LCD brightness at all, though changing the backlight setting in one reflects the value read by the other. "xset dpms force off" does work.

I've tried booting with acpi_backlight=vendor, but that only results in no backlight control available from userspace whatsoever (running xbacklight returns nothing, instead of the current backlight setting).
Comment 1 Michel Alexandre Salim 2011-02-17 16:44:11 UTC
Created attachment 43501 [details]
Xorg log
Comment 2 Michel Alexandre Salim 2011-02-17 16:44:53 UTC
Created attachment 43502 [details]
dmesg
Comment 3 Michel Alexandre Salim 2011-02-17 16:47:19 UTC
Created attachment 43503 [details]
register dumps
Comment 4 Michel Alexandre Salim 2011-02-17 16:47:54 UTC
Created attachment 43504 [details]
VBIOS dump
Comment 5 Chris Wilson 2011-02-24 02:19:57 UTC

*** This bug has been marked as a duplicate of bug 34437 ***
Comment 6 Michel Alexandre Salim 2011-02-28 06:00:09 UTC
Reported fix does not actually work
Comment 7 Michel Alexandre Salim 2011-07-13 06:04:53 UTC
Created attachment 49035 [details] [review]
mjg's i915 native GPU backlight control patch from linux-next

Applying Matthew Garrett's latest iteration of the i915 native backlight patch,
already in linux-next, on top of Linus' 3.0rc7 fixes the issue for me.

Hope to see this incorporated soon (the native backlight infrastructure is already in Linus' tree, it's only the per-driver implementations that have not landed).

Is there a way to disable *both* backlight=video and backlight=vendor, and leave only the native backlight interface present? Right now I have both acpi_video0 and intel-backlight, and GNOME Power Manager prefers the former.
Comment 8 Michel Alexandre Salim 2011-11-24 05:31:00 UTC
Patch has been applied by keithp a few releases back