Bug 34646 - [bisected piketon]ogles2conform GL2Tests/GL/gl_FragCoord/gl_FragCoord_w_frag.test
[bisected piketon]ogles2conform GL2Tests/GL/gl_FragCoord/gl_FragCoord_w_frag....
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: glsl-compiler
git
All Linux (All)
: high major
Assigned To: Kenneth Graunke
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-23 21:56 UTC by fangxun
Modified: 2011-03-02 18:00 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
gl_FragCoord_w_frag.test output file (22.08 KB, text/plain)
2011-02-23 21:56 UTC, fangxun
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fangxun 2011-02-23 21:56:10 UTC
Created attachment 43741 [details]
gl_FragCoord_w_frag.test output file

System Environment:
--------------------------
Arch:           x86_64
Platform:       piketon 
Libdrm:         (master)2.4.23-16-ge6018c25ca63fa6066d8fa6e57373030d07b0392
Mesa:           (master)6d1f28d6c045f768da2eee779006535acf382cce
Xserver:         (master)xorg-server-1.9.99.902-3-g93a73993708b1345c86ec3ec06b02ed236595673
Xf86_video_intel:   (master)2.14.0-36-g8b3b10825741da095a8560d7e488e98be0b62aa9
Kernel: (drm-intel-next)f4166442e7533ca2668d639d939b1bbdb8e6b423

Bug detailed description:
-------------------------
The test result is changed from pass to fail. This regression happens on piketon. Bisect shows 4a3b28113c3d23ba21bb8b8f5ebab7c567083a6d is the first bad commit.
commit 4a3b28113c3d23ba21bb8b8f5ebab7c567083a6d
Author:     Kenneth Graunke <kenneth@whitecape.org>
AuthorDate: Sat Feb 19 16:48:24 2011 -0800
Commit:     Kenneth Graunke <kenneth@whitecape.org>
CommitDate: Tue Feb 22 10:52:44 2011 -0800

    i965/fs: Correctly set up gl_FragCoord.w on Sandybridge.

    pixel_w is the final result; wpos_w is used on gen4 to compute it.

    NOTE: This is a candidate for the 7.10 branch.

    Reviewed-by: Eric Anholt <eric@anholt.net>
Comment 1 Kenneth Graunke 2011-03-01 01:11:44 UTC
Reverted the patch for now.  Also, since it (unfortunately) got cherry-picked to 7.10, I reverted it there, too.
Comment 2 fangxun 2011-03-02 18:00:40 UTC
Verified with Mesa(master)bbd9616838623c637e5f24bef62c068e2c9c3775.