Bug 3481 - can't compile with gcc4
Summary: can't compile with gcc4
Alias: None
Product: dbus
Classification: Unclassified
Component: core (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Havoc Pennington
QA Contact:
Depends on:
Reported: 2005-06-06 12:55 UTC by Daniel Stone
Modified: 2006-08-01 10:26 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:

Log of compilation (13.64 KB, text/plain)
2005-08-15 08:09 UTC, Stef van der Made
Fix for Pyrex-0.9.3 to get dbus to compile from CVS (4.43 KB, patch)
2005-08-17 14:14 UTC, Stef van der Made
Details | Splinter Review

Description FreeDesktop Bugzilla Database Corruption Fix User 2005-06-06 12:55:46 UTC
When I try to compile dbus I get the following error:
dbus_bindings.c: in 
function '__pyx_f_13dbus_bindings_cunregister_function_handler':
dbus_bindings.c:1001: error: invalid lvalue in assignment
dbus_bindings.c:1046: error: invalid lvalue in assignment
Comment 1 Colin Walters 2005-06-15 21:33:42 UTC
This is fixed in CVS.
Comment 2 Stef van der Made 2005-08-15 08:09:32 UTC
Created attachment 2867 [details]
Log of compilation

I've downloaded dbus from CVS on 15Aug2005 and tried to compile it. The version
in CVS that I downloaded still doesn't compile on gcc-4.0.1.
Comment 3 Stef van der Made 2005-08-17 14:14:57 UTC
Created attachment 2914 [details] [review]
Fix for Pyrex-0.9.3 to get dbus to compile from CVS

The attached patch will fix the issue with DBUS. the issue however is located
in the Pyrex software that is not compatible with gcc-4.0.1. The patch works
against pyrex-0.9.3

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.