Bug 34851 - Xdmx on xorg-server 1.10.0 segment fault
Xdmx on xorg-server 1.10.0 segment fault
Status: NEW
Product: xorg
Classification: Unclassified
Component: Server/DDX/dmx
x86-64 (AMD64) Linux (All)
: medium normal
Assigned To: dmx-bugs
Xorg Project Team
: 24609 (view as bug list)
Depends on:
  Show dependency treegraph
Reported: 2011-02-28 16:02 UTC by Jonathan Sattelberger
Modified: 2012-06-01 03:33 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:

glxinfo/ldd glxinfo (direct rendering enabled) (28.43 KB, text/plain)
2011-02-28 16:02 UTC, Jonathan Sattelberger
no flags Details
glxinfo/ldd glxinfo (indirect rendering enabled) (25.42 KB, text/plain)
2011-02-28 16:03 UTC, Jonathan Sattelberger
no flags Details
xorg-server 1.10.0 segment fault (11.16 KB, text/plain)
2011-02-28 16:04 UTC, Jonathan Sattelberger
no flags Details
xorg-server 1.9.0 segment fault (10.87 KB, text/plain)
2011-02-28 16:04 UTC, Jonathan Sattelberger
no flags Details
Patch v1 (643 bytes, patch)
2012-06-01 03:33 UTC, Gary van der Merwe
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Sattelberger 2011-02-28 16:02:36 UTC
Created attachment 43945 [details]
glxinfo/ldd glxinfo (direct rendering enabled)

Over the weekend I built xorg-server 1.10.0 hoping to run Xdmx with GLX(proxy) successfully. Xdmx by itself runs perfectly fine, but as soon as I attempt to load glxinfo or glxgears I am greeted with a wonderful segment fault. I've tried running glxinfo/gears with both indirect and direct rendering enabled. I've also tried running it with the proprietary nVidia and Mesa GL libraries. No success. 

(Side note: I haven't been able to run Xdmx with GLX(proxy) support with xorg-server versions newer than 1.1.1.)

The systems running Xdmx are identical in software and hardware.

I've attached the the build log for Xorg-server with DMX support enabled. The backtrace from Xdmx with GLXproxy enabled (assuming I did it correctly). glxinfo direct/indirect rendering log with the latest proprietary nVidia drivers installed. I've also included the backtrace for the Xdmx version compiled with Ubuntu 10.10 (xorg-server 1.9 I believe...).

Any thoughts?

Comment 1 Jonathan Sattelberger 2011-02-28 16:03:11 UTC
Created attachment 43946 [details]
glxinfo/ldd glxinfo (indirect rendering enabled)

glxinfo/ldd glxinfo (direct rendering enabled)
Comment 2 Jonathan Sattelberger 2011-02-28 16:04:04 UTC
Created attachment 43947 [details]
xorg-server 1.10.0 segment fault
Comment 3 Jonathan Sattelberger 2011-02-28 16:04:42 UTC
Created attachment 43948 [details]
xorg-server 1.9.0 segment fault
Comment 4 Julien Cristau 2011-03-01 02:10:13 UTC
From a quick look, commit 7d74690536b64f7b8e8036507ab7790807349c50 removed the call to GlxWrapInitVisuals from mi/miinitext.c.  glxProxy's InitVisuals function allocated __glXActiveScreens.  That code was removed in commit a715de7f11afeda7798f0882148a94d4db2291e6 as unused.

commit 7d74690536b64f7b8e8036507ab7790807349c50
Author: Kristian Høgsberg <krh@redhat.com>
Date:   Sun Oct 14 15:39:21 2007 -0400

    Simplify and clean up GLX visual initialization.
    Instead of the fragile setup where we filter the modes common between the
    DDX generated GLX visuals and the DRI driver generated fbconfigs, we now
    just take the fbconfigs returned by the DRI driver to be our supported set.

commit a715de7f11afeda7798f0882148a94d4db2291e6
Author: Jamey Sharp <jamey@minilop.net>
Date:   Tue May 25 13:10:05 2010 -0700

    dmx: Delete unused GLX visual matching code.
    Kristian deleted this API from the rest of the server in 2007, in commit
    Signed-off-by: Jamey Sharp <jamey@minilop.net>
    Reviewed-by: Kristian Høgsberg <krh@bitplanet.net>
Comment 5 Stefan 2011-06-27 12:32:42 UTC
*** Bug 24609 has been marked as a duplicate of this bug. ***
Comment 6 Stefan 2011-06-27 12:43:21 UTC
I am also affected by this bug on Ubuntu 11.04 and OpenSuSE 14. I will investigate reverting those commits and trying to build and test.

If any developer needs more info logs etc, please let me know
Comment 7 Gary van der Merwe 2012-06-01 03:33:45 UTC
Created attachment 62369 [details] [review]
Patch v1

I was able to get glxproxy working with this patch, and by setting  "export LIBGL_ALWAYS_INDIRECT=1" when running a gl app.