Bug 34948 - [i915gm] GPU lockup (ESR: 0x00000001 IPEHR: 0x02000004)
Summary: [i915gm] GPU lockup (ESR: 0x00000001 IPEHR: 0x02000004)
Status: RESOLVED DUPLICATE of bug 34014
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.6 (2010.12)
Hardware: x86 (IA32) Linux (All)
: highest critical
Assignee: Chris Wilson
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-02 17:43 UTC by Bryce Harrington
Modified: 2011-03-15 01:53 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
BootDmesg.txt (53.07 KB, text/plain)
2011-03-02 17:45 UTC, Bryce Harrington
no flags Details
CurrentDmesg.txt (2.21 KB, text/plain)
2011-03-02 17:45 UTC, Bryce Harrington
no flags Details
XorgLog.txt (91.87 KB, text/plain)
2011-03-02 17:47 UTC, Bryce Harrington
no flags Details
i915_error_state.txt (763.77 KB, text/plain)
2011-03-02 17:48 UTC, Bryce Harrington
no flags Details
BootDmesg.txt (53.54 KB, text/plain)
2011-03-02 17:51 UTC, Bryce Harrington
no flags Details
CurrentDmesg.txt (1.47 KB, text/plain)
2011-03-02 17:51 UTC, Bryce Harrington
no flags Details
XorgLog.txt (53.87 KB, text/plain)
2011-03-02 17:51 UTC, Bryce Harrington
no flags Details
i915_error_state.txt (758.67 KB, text/plain)
2011-03-02 17:52 UTC, Bryce Harrington
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bryce Harrington 2011-03-02 17:43:11 UTC
Forwarding this bug from Ubuntu reporter David Coggins:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/727594

[Problem]
We're seeing a variety of GPU lockup reports like this one, mainly from i915 and i945 (but also some on 965 and other chips).  This particular class of lockup seems to occur randomly during usage, always has an ESR 0x00000001 and IPEHR 0x020000xx.

Users with this bug see it with the Ubuntu kernel as well as the current daily kernel (with default kernel config and no ubuntu changes).

[Original Description]
As instructed by Bryce I installed the following kernel on my Asus eee pc 701 running natty: 
" Please test with the following kernel:

  http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/current/ "

by doing sudo dpkg -i linux-image....deb

Then I ran update manager. 

After rebooting I browsed with google chrome. The system froze after 5 minutes.

I rebooted the same kernel and immediately got this problem popup. In addition there is font corruption - part of the letter t is missing in the browser.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-video-intel 2:2.14.0-1ubuntu11
Uname: Linux 2.6.38-999-generic i686
Architecture: i386
Chipset: i915gm
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 800x480
 edid-base64:
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1680x1050 1280x1024 1280x1024 1280x960 1152x864 1024x768 1024x768 1024x768 832x624 800x600 800x600 800x600 800x600 640x480 640x480 640x480 640x480 720x400
 edid-base64: AP///////wBMLX4CMjJFTQ4RAQMOLx54KtUVpFVJmicUUFS/74CzAIGAgUBxTwEBAQEBAQEBfC6QoGAaHkAwIDYA2igRAAAaAAAA/QA4Sx5RDgAKICAgICAgAAAA/ABTeW5jTWFzdGVyCiAgAAAA/wBIOU5QNDAwMTk3CiAgAM8=
Date: Wed Mar  2 15:23:13 2011
DistUpgraded: Yes, recently upgraded Log time: 2011-02-17 19:00:58.983764
DistroCodename: natty
DistroVariant: ubuntu
DumpSignature: c38b9ae8 (ESR: 0x00000001 IPEHR: 0x02000004)
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
GraphicsCard:
 Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2592] (rev 04) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:82d9]
   Subsystem: ASUSTeK Computer Inc. Device [1043:82d9]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110202)
InterpreterPath: /usr/bin/python2.7
MachineType: ASUSTeK Computer INC. 701
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:
 
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-999-generic root=UUID=3893e3fd-c2b4-40ec-9810-5a9aba86cbd4 ro crashkernel=384M-2G:64M,2G-:128M quiet splash vt.handoff=7
ProcKernelCmdLine_: BOOT_IMAGE=/boot/vmlinuz-2.6.38-999-generic root=UUID=3893e3fd-c2b4-40ec-9810-5a9aba86cbd4 ro crashkernel=384M-2G:64M,2G-:128M quiet splash vt.handoff=7
RelatedPackageVersions:
 xserver-xorg             1:7.6~3ubuntu8
 libdrm2                  2.4.23-1ubuntu3
 xserver-xorg-video-intel 2:2.14.0-1ubuntu11
Renderer: Unknown
SourcePackage: xserver-xorg-video-intel
Title: [i915gm] GPU lockup c38b9ae8 (ESR: 0x00000001 IPEHR: 0x02000004)
UpgradeStatus: Upgraded to natty on 2011-02-24 (5 days ago)
UserGroups:
 
dmi.bios.date: 05/04/2008
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1001
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 701
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTek Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1001:bd05/04/2008:svnASUSTeKComputerINC.:pn701:pvrx.x:rvnASUSTeKComputerINC.:rn701:rvrx.xx:cvnASUSTekComputerINC.:ct10:cvrx.x:
dmi.product.name: 701
dmi.product.version: x.x
dmi.sys.vendor: ASUSTeK Computer INC.
version.compiz: compiz 1:0.9.4-0ubuntu3
version.libdrm2: libdrm2 2.4.23-1ubuntu3
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1~git20110215.cc1636b6-0ubuntu2
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu8
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-1ubuntu11
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu5
Comment 1 Bryce Harrington 2011-03-02 17:43:55 UTC
This could be a dupe of https://bugs.freedesktop.org/show_bug.cgi?id=34307 although since it's a different user and different error codes I'm reporting it separately.
Comment 2 Bryce Harrington 2011-03-02 17:45:12 UTC
Created attachment 44044 [details]
BootDmesg.txt
Comment 3 Bryce Harrington 2011-03-02 17:45:31 UTC
Created attachment 44045 [details]
CurrentDmesg.txt
Comment 4 Bryce Harrington 2011-03-02 17:47:35 UTC
Created attachment 44046 [details]
XorgLog.txt
Comment 6 Bryce Harrington 2011-03-02 17:51:12 UTC
Created attachment 44048 [details]
BootDmesg.txt
Comment 7 Bryce Harrington 2011-03-02 17:51:33 UTC
Created attachment 44049 [details]
CurrentDmesg.txt
Comment 8 Bryce Harrington 2011-03-02 17:51:53 UTC
Created attachment 44050 [details]
XorgLog.txt
Comment 9 Bryce Harrington 2011-03-02 17:52:20 UTC
Created attachment 44051 [details]
i915_error_state.txt
Comment 10 Chris Wilson 2011-03-15 01:53:40 UTC

*** This bug has been marked as a duplicate of bug 34014 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.