Bug 35103 - [SNB/IVB] “[drm:pch_irq_handler] *ERROR* PCH poison interrupt” after S3 resume on a SugarBay
[SNB/IVB] “[drm:pch_irq_handler] *ERROR* PCH poison interrupt” after S3 resum...
Status: VERIFIED FIXED
Product: DRI
Classification: Unclassified
Component: DRM/Intel
unspecified
All Linux (All)
: medium normal
Assigned To: Chris Wilson
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-07 18:42 UTC by bo.b.wang
Modified: 2012-06-06 20:03 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg.txt is the bug's dmesg information (41.35 KB, text/plain)
2011-03-07 18:42 UTC, bo.b.wang
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description bo.b.wang 2011-03-07 18:42:56 UTC
Created attachment 44218 [details]
dmesg.txt is the bug's dmesg information

System Environment:
--------------------------
Platform:        Sugarbay
Libdrm:         (master)2.4.24-6-g3b04c73650b5e9bbcb602fdb8cea0b16ad82d0c0
Mesa:           (7.10)68cdea9fb2c33aba5459fd79f57faadf9800e5bb
Xserver:                (master)xorg-server-1.10.0
Xf86_video_intel:               (master)2.14.901
Cairo:          (master)f1d313e042af89b2f5f5d09d3eb1703d0517ecd7
Kernel: (drm-intel-fixes)91355834646328e7edc6bd25176ae44bcd7386c7

Bug detailed description:
-------------------------
When I do “ echo mem >/sys/power/state” ,the memory can be suspended. And Then I press power button to wake up memory, the Memory can be waked up normally. However, An error “[drm:pch_irq_handler] *ERROR* PCH poison interrupt”message appears in the terminal. This issue occurs in Sugarbar rev09 GT2 every time. But never have occurred int Sugarbar rev09 GT1.
It’s kernel regression.
Reproduce steps:
----------------
1.	Don’t start X
2.	echo mem>/sys/power/state
3.	press power button to wake up
Comment 1 Gordon Jin 2011-03-07 18:51:14 UTC
The "bad" PCH for the "Sugarbay rev09 GT2" is DH SDP board.
The "working" PCH for the "Sugarbay rev09 GT1" is Intel DH67CL board.
Comment 2 Chris Wilson 2011-03-07 23:50:52 UTC
It's not a regression, as since we weren't checking for the PCH interrupts earlier we have no idea if this was recently introduced. I've seen these on a i5-2500 which is a GT1 device.
Comment 3 Gordon Jin 2011-03-08 01:02:18 UTC
right, it should not be regression. It's a new machine for us.
Comment 4 Gordon Jin 2011-05-30 19:22:50 UTC
Chris, can you evaluate the impact of this bug?
Comment 5 Jesse Barnes 2011-06-08 11:31:29 UTC
Not sure what it means, but reading poisoned memory sounds like a serious issue...  But it could also be a spurious interrupt from resume.
Comment 6 meng 2011-06-17 00:58:53 UTC
The problem also exists on our IvyBridge . 
-----------------------------------------------------
Libdrm:     (master)2.4.26
Mesa:    (master)8875dd58719b978283e89acf04422a4eaf9b021d
Xserver:    
(server-1.10-branch)xorg-server-1.10.2-11-g9551f5041915fa00ca243a279efb55de2ff11a00
Xf86_video_intel:(master)2.15.0-96-ga1ee4b930846d4ba9274028c08800b882fc926f1
Cairo:     (master)3b9c8744898823a4b09917f0540a324318fef726
Libva:     (master)3c1b6875b589f3a40709a889da85b979e34db625
Kernel:     (drm-intel-fixes)6a574b5b9b186e28abd3e571dfd1700c5220b510
Comment 7 Yi Sun 2011-09-12 20:43:57 UTC
After running the testdisplay with HDMI and VGA on IVB platform, we unplug the VGA monitor. Then the error information will appears.
Comment 8 Daniel Vetter 2012-06-06 15:05:42 UTC
Should be fixed with

commit 23e81d691a813839020f6e516b398d0f9369fe8b
Author: Adam Jackson <ajax@redhat.com>
Date:   Wed Jun 6 15:45:44 2012 -0400

    drm/i915: pch_irq_handler -> {ibx, cpt}_irq_handler

in drm-intel-fixes. It's simply a matter of us complaining about an interrupt with new (but harmless) meaning.