Bug 35377 - [SNB]when play SA30029.vc1 with vaapi , the window show garbage
[SNB]when play SA30029.vc1 with vaapi , the window show garbage
Status: RESOLVED FIXED
Product: libva
Classification: Unclassified
Component: intel
unspecified
x86 (IA32) Linux (All)
: medium normal
Assigned To: Gwenole Beauchesne
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-03-16 23:06 UTC by Hai
Modified: 2013-03-22 05:22 UTC (History)
2 users (show)

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hai 2011-03-16 23:06:47 UTC
System Environment:
--------------------------
Platform:   SNB
Libdrm:		(master)2.4.24-6-g3b04c73650b5e9bbcb602fdb8cea0b16ad82d0c0
Mesa:		(7.10)d59da648178f04f68232ee8a8994843c6b547af8
Xserver:		(master)xorg-server-1.10.0
Xf86_video_intel:		(master)2.14.901-3-g014fc7abb7b2cc2110e3ab9a0bd6f7cff2c64c05
Cairo:		(master)f2f65684f0c6e1a26741bf96bb9bec286457a571
Kernel:	(drm-intel-fixes) 467cffba85791cdfce38c124d75bd578f4bb8625
Libva: (master)b7ff2141aeb2adbf5743fed7910a62d971c15013

Bug detailed description:
-------------------------
When I play SA30029.vc1,the window show some garbage. It works Ok
with xv output. 
Reproduce steps:
----------------
1. mplayer -vo vaapi -va vaapi SA30029.vc1 -fps 5
Comment 1 Gwenole Beauchesne 2011-10-06 06:45:59 UTC
Hi, I made a fix to FFmpeg. However, this may not be related because sometimes it works, sometimes it doesn't. So, the driver might be used an uninitialized variable. I will look into for GStreamer too.
Comment 2 cc 2012-07-18 14:47:45 UTC
This issue still exist on SNB.

Libva:		(master)32a8cbd8bb1652473e49f933545b6ace716fd5dd
Libva_intel_driver:		(master)b70b40930fa29304d360389ec9c4c9b1a5661216
Comment 3 Ouping Zhang 2013-03-22 05:22:17 UTC
with the latest driver.
This issue can't be reproduced.
file name	Result	Y SSIM extreme	Y SSIM average	U SSIM extreme	U SSIM average	V SSIM extreme	V SSIM average	frame no	dumped frame 
SA30029.vc1	PASS	1	1	1	1	1	1	24	24