Bug 35401 - [SNB]when play SMH0010.rcv with vaapi , the window flickers and will show garbage
Summary: [SNB]when play SMH0010.rcv with vaapi , the window flickers and will show gar...
Status: RESOLVED WORKSFORME
Alias: None
Product: libva
Classification: Unclassified
Component: intel (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: haihao
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-17 19:36 UTC by Hai
Modified: 2015-11-18 07:28 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Hai 2011-03-17 19:36:50 UTC
System Environment:
--------------------------
Platform:   SNB
Libdrm:        (master)2.4.24-6-g3b04c73650b5e9bbcb602fdb8cea0b16ad82d0c0
Mesa:        (7.10)d59da648178f04f68232ee8a8994843c6b547af8
Xserver:        (master)xorg-server-1.10.0
Xf86_video_intel:       
(master)2.14.901-3-g014fc7abb7b2cc2110e3ab9a0bd6f7cff2c64c05
Cairo:        (master)f2f65684f0c6e1a26741bf96bb9bec286457a571
Kernel:    (drm-intel-fixes) 467cffba85791cdfce38c124d75bd578f4bb8625
Libva: (master)b7ff2141aeb2adbf5743fed7910a62d971c15013

Bug detailed description:
-------------------------
When I play SMH0010.rcv(1920x1080 with Extended Motion
Vectors) ,the window flickers and will show garbage . It works Ok
with xv output. 
Reproduce steps:
----------------
1. mplayer -vo vaapi -va vaapi SMH0010.rcv -fps 30
Comment 1 cc 2012-07-18 14:47:14 UTC
This issue still exist on SNB.

Libva:		(master)32a8cbd8bb1652473e49f933545b6ace716fd5dd
Libva_intel_driver:		(master)b70b40930fa29304d360389ec9c4c9b1a5661216
Comment 2 Oleksij Rempel 2012-07-25 07:03:47 UTC
here is video display this issue http://youtu.be/nCzUAcmO-QA
Comment 3 Oleksij Rempel 2012-07-25 07:05:22 UTC
oops wrong bug.
Comment 4 ykzhao 2013-11-29 02:26:08 UTC
Will you please try the latest code and see whether the issue still exists?

Thanks.
     Yakui
Comment 5 haihao 2015-11-18 07:28:37 UTC
No response from user for a long time so closing as WORKSFORME, Feel free to reopen this bug if you still experience the issue


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.