Bug 35477 - [vnc/librecord] Xorg segfaults with intel driver after suspend/resume in KDE 4.6
Summary: [vnc/librecord] Xorg segfaults with intel driver after suspend/resume in KDE 4.6
Status: RESOLVED DUPLICATE of bug 30032
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: 7.4 (2008.09)
Hardware: Other Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
Depends on:
Reported: 2011-03-20 20:15 UTC by Richard H.
Modified: 2011-03-21 09:53 UTC (History)
0 users

See Also:
i915 platform:
i915 features:

backtrace from the crash (2.66 KB, text/plain)
2011-03-20 20:15 UTC, Richard H.
no flags Details

Description Richard H. 2011-03-20 20:15:21 UTC
Created attachment 44644 [details]
backtrace from the crash

This bug happens on both x86 and amd64, tried two systems, one has a 965 card, one a 945. Both are using KMS, and both are running Xorg 7.4 using xf86-video-intel. Both of them are running Gentoo, one with 2.6.37, one with 2.6.34. This bug effectively stops me using KDE Plasma, I have reported the bug there and got sent here. The bug report can be found here:


What happens is the following:

* I start up Xorg, enter KDE 4.6, all works well.
* I suspend, and later resume
* All works well
* After a few seconds or minutes, I got thrown back to kdm.

Using firefox speeds up the process to a few seconds, but still without using it the session gets terminated in a few minutes.

I am attaching a backtrace, but I couldn't get a full one, as it seems to have no end (tried unter #11.000, then gave up). It cycles in the pattern I have written in the last line of the attached file.

This bug seems to have been introduced in 7.4, I didn't have any problems before.
Comment 1 Richard H. 2011-03-20 20:16:48 UTC
I am using LXDE now, no crashes in there. Even using various effects doesn't lead to a crash.
Comment 2 Richard H. 2011-03-21 02:44:15 UTC
It seems this might be caused by x11vnc, which gets started in KDE, but not in other DE's, because of the startup-file.I will continue to investigate.

One of the systems did not have any of these crashes when x11vnc was not running. The other one will be tested today.
Comment 3 Chris Wilson 2011-03-21 03:27:55 UTC
Another vnc + librecord.so infinite recursion.
Comment 4 Richard H. 2011-03-21 03:56:15 UTC
can this be solved in other ways than simply not using x11vnc?
Comment 5 Julien Cristau 2011-03-21 09:53:12 UTC
It's fixed in xserver 1.10.

*** This bug has been marked as a duplicate of bug 30032 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.