Bug 35530 - [PATCH] Update Sri Lankan (lk) keymap to use Sinhala keysyms
Summary: [PATCH] Update Sri Lankan (lk) keymap to use Sinhala keysyms
Status: RESOLVED FIXED
Alias: None
Product: xkeyboard-config
Classification: Unclassified
Component: General (show other bugs)
Version: unspecified
Hardware: Other Linux (All)
: medium enhancement
Assignee: xkb
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-21 20:19 UTC by Harshula Jayasuriya
Modified: 2011-03-24 15:48 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Update lk keymap to use Sinhala keysyms (4.41 KB, patch)
2011-03-21 20:21 UTC, Harshula Jayasuriya
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Harshula Jayasuriya 2011-03-21 20:19:41 UTC
I've updated the Sri Lankan (lk) XKB keymap to use the Sinhala keysyms instead of the Unicode based magic numbers. However, note that this update is dependent on the user's system having the following updates:

1) http://cgit.freedesktop.org/xorg/proto/x11proto/commit/?id=423f5faddbb1023d0c1cf55b9d1da4397aa1aa26

2) http://cgit.freedesktop.org/xorg/lib/libX11/commit/?id=25eb76b3d2726f2f1de759901971ae53b2539dc4

cya,
#
Comment 1 Harshula Jayasuriya 2011-03-21 20:21:48 UTC
Created attachment 44701 [details] [review]
Update lk keymap to use Sinhala keysyms
Comment 2 Peter Hutterer 2011-03-21 21:59:42 UTC
patch looks sane to me, but we need to get libX11 and xproto releases out before we can merge this into xkeyboard-config. Sergey, what are your current release schedules?
Comment 3 Sergey V. Udaltsov 2011-03-22 13:55:06 UTC
I am going to make special release for GNOME3, in a couple of weeks. Next release is planned in May. Then - September. Please advise when would be the best moment to include that patch?
Comment 4 Daniel Stone 2011-03-22 15:10:34 UTC
On Tue, Mar 22, 2011 at 01:55:09PM -0700,Sergey V. Udaltsov wrote:
> I am going to make special release for GNOME3, in a couple of weeks. Next
> release is planned in May. Then - September. Please advise when would be the
> best moment to include that patch?

Well, at the moment, we don't have an xproto shipped with these changes,
but we can fix that.
Comment 5 Peter Hutterer 2011-03-22 18:58:55 UTC
xproto 7.0.21 was just released, so feel free to require that for the
sinhala keysyms.
Comment 6 Sergey V. Udaltsov 2011-03-23 17:30:06 UTC
I do not specify runtime dependency on xproto. So I will just commit the patch:)
Comment 7 Harshula Jayasuriya 2011-03-23 18:15:46 UTC
The update to lk layout to use keysyms also requires a new version of libX11 to be released. i.e. it needs http://cgit.freedesktop.org/xorg/lib/libX11/commit/?id=25eb76b3d2726f2f1de759901971ae53b2539dc4

If the updated lk layout is released and used by a user before the aforementioned patch is released in a new version of libX11, the lk layout will not work. i.e. It will be a regression.

Is there a way we can hold this change back until a new version of libX11 is released?
Comment 8 Peter Hutterer 2011-03-23 18:29:44 UTC
On Wed, Mar 23, 2011 at 06:15:47PM -0700, bugzilla-daemon@freedesktop.org wrote:
> Is there a way we can hold this change back until a new version of libX11 is
> released?

or just put requires into xkeyboard-config. If we require something, we
should just state so. It'll certainly save time for distributors and testers
having to triage bugs caused by an unmet dependency.
Comment 9 Harshula Jayasuriya 2011-03-23 18:50:34 UTC
Build dependencies are:
a) http://cgit.freedesktop.org/xorg/proto/x11proto/commit/?id=423f5faddbb1023d0c1cf55b9d1da4397aa1aa26 in x11proto is needed by libX11 once libX11 has http://cgit.freedesktop.org/xorg/lib/libX11/commit/?id=25eb76b3d2726f2f1de759901971ae53b2539dc4

Runtime dependencies are:
b) The updated lk layout needs a libX11 that was built with http://cgit.freedesktop.org/xorg/lib/libX11/commit/?id=25eb76b3d2726f2f1de759901971ae53b2539dc4
Comment 10 Sergey V. Udaltsov 2011-03-24 13:34:14 UTC
I do not see any need in build dependencies. The build won't break if we do not have those keysyms around.

How would you propose to check the runtime dependencies? xkbcomp will fail, that's it.
Comment 11 Peter Hutterer 2011-03-24 15:48:32 UTC
Moved this discussion to Bug 35640 to keep this bug clean. Patch attached there too.


bug/show.html.tmpl processed on Mar 27, 2017 at 12:39:21.
(provided by the Example extension).