Bug 35647 - [i915gm] GPU lockup (ESR: 0x00000001 IPEHR: 0x7f9c000f)
Summary: [i915gm] GPU lockup (ESR: 0x00000001 IPEHR: 0x7f9c000f)
Status: RESOLVED DUPLICATE of bug 34014
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.6 (2010.12)
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Chris Wilson
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2011-03-25 00:34 UTC by Bryce Harrington
Modified: 2011-03-26 02:22 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
i915_error_state.txt (757.74 KB, text/plain)
2011-03-25 00:36 UTC, Bryce Harrington
no flags Details
XorgLog.txt (28.01 KB, text/plain)
2011-03-25 00:36 UTC, Bryce Harrington
no flags Details
CurrentDmesg.txt (1.65 KB, text/plain)
2011-03-25 00:36 UTC, Bryce Harrington
no flags Details
BootDmesg.txt (48.47 KB, text/plain)
2011-03-25 00:37 UTC, Bryce Harrington
no flags Details
Round up GTT allocations to next even tile (5.33 KB, patch)
2011-03-25 03:28 UTC, Chris Wilson
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Bryce Harrington 2011-03-25 00:34:10 UTC
Forwarding this bug from Ubuntu reporter Zhmak:
http://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/740786

[Problem]
GPU lockup on i915gm, with kernel that includes commit b5b5ac2d patched in.

See also bug #35516 which I think is the same issue, closed perhaps too optimistically?

[Original Description]
Sometimes getting "melting snow" effect on screen before login screen.
in dmesg:
[   31.240026] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[   31.241477] [drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -11 (awaiting 1742 at 1740, next 1743)
[   31.243307] [drm:i915_reset] *ERROR* Failed to reset chip.


Also getting flickering trash in new pop-up windows while its opening in classic gnome desktop mode. Opening same pop-up again looks fine.

ProblemType: Crash
DistroRelease: Ubuntu 11.04
Package: xserver-xorg-video-intel 2:2.14.0-4ubuntu4
ProcVersionSignature: Ubuntu 2.6.38-7.38-generic 2.6.38
Uname: Linux 2.6.38-7-generic i686
Architecture: i386
Chipset: i915gm
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: None
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1024x600
 edid-base64:
DRM.card0.VGA.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes: 
 edid-base64:
Date: Wed Mar 23 10:48:08 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DuplicateSignature: (ESR: 0x00000001 IPEHR: 0x7f9c000f)
ExecutablePath: /usr/share/apport/apport-gpu-error-intel.py
GraphicsCard:
 Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller [8086:2592] (rev 04) (prog-if 00 [VGA controller])
   Subsystem: ASUSTeK Computer Inc. Device [1043:82d9]
   Subsystem: ASUSTeK Computer Inc. Device [1043:82d9]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20110321)
InterpreterPath: /usr/bin/python2.7
MachineType: ASUSTeK Computer INC. 900
ProcCmdline: /usr/bin/python /usr/share/apport/apport-gpu-error-intel.py
ProcEnviron:
 
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=75374be3-dac3-432a-946e-99728dd11078 ro quiet splash vt.handoff=7
ProcKernelCmdLine_: BOOT_IMAGE=/boot/vmlinuz-2.6.38-7-generic root=UUID=75374be3-dac3-432a-946e-99728dd11078 ro quiet splash vt.handoff=7
RelatedPackageVersions:
 xserver-xorg             1:7.6~3ubuntu11
 libdrm2                  2.4.23-1ubuntu5
 xserver-xorg-video-intel 2:2.14.0-4ubuntu4
Renderer: Unknown
SourcePackage: xserver-xorg-video-intel
Title: [i915gm] GPU lockup (ESR: 0x00000001 IPEHR: 0x7f9c000f)
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:
 
dmi.bios.date: 03/03/2009
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1006
dmi.board.asset.tag: To Be Filled By O.E.M.
dmi.board.name: 900
dmi.board.vendor: ASUSTeK Computer INC.
dmi.board.version: x.xx
dmi.chassis.asset.tag: 0x00000000
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTek Computer INC.
dmi.chassis.version: x.x
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1006:bd03/03/2009:svnASUSTeKComputerINC.:pn900:pvr0704:rvnASUSTeKComputerINC.:rn900:rvrx.xx:cvnASUSTekComputerINC.:ct10:cvrx.x:
dmi.product.name: 900
dmi.product.version: 0704
dmi.sys.vendor: ASUSTeK Computer INC.
version.compiz: compiz 1:0.9.4git20110322-0ubuntu1
version.libdrm2: libdrm2 2.4.23-1ubuntu5
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.1-0ubuntu3
version.xserver-xorg: xserver-xorg 1:7.6~3ubuntu11
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu6
Comment 1 Bryce Harrington 2011-03-25 00:36:03 UTC
Created attachment 44807 [details]
i915_error_state.txt
Comment 2 Bryce Harrington 2011-03-25 00:36:25 UTC
Created attachment 44808 [details]
XorgLog.txt
Comment 3 Bryce Harrington 2011-03-25 00:36:50 UTC
Created attachment 44809 [details]
CurrentDmesg.txt
Comment 4 Bryce Harrington 2011-03-25 00:37:08 UTC
Created attachment 44810 [details]
BootDmesg.txt
Comment 5 Bryce Harrington 2011-03-25 00:40:21 UTC
Another similar bug, with IPEHR: 0x7d8e0001:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/741466
Comment 6 Bryce Harrington 2011-03-25 00:41:20 UTC
Another dupe:
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/741578
Comment 7 Chris Wilson 2011-03-25 03:28:15 UTC
Created attachment 44816 [details] [review]
Round up GTT allocations to next even tile

Bryce, are you still testing with the "round up to fence size"? If not the attached which should fix the i8xx issues might help here.
Comment 8 James Le Cuirot 2011-03-25 15:03:04 UTC
I'm seeing a very similar lockup with ESR: 0x00000001 and IPEHR: 0x02000011... whatever those mean. :) But I tried the attached patch against Gentoo's 2.6.38 and it's still happening, I'm afraid. One of the Ubuntu bugs mentioned Chrome. That's where I see it too and yet I managed to play Black & White under Wine for a good hour or so without problems. 2.6.37.4 seems fine.
Comment 9 Chris Wilson 2011-03-26 02:22:22 UTC
Ok, this is a slight variation on the theme (only in that the batch contains more than the single 3D blit of the others), but the killer operation looks the semantically the same.

*** This bug has been marked as a duplicate of bug 34014 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.