Bug 35808 - [SNB] KDE graphic glitches
Summary: [SNB] KDE graphic glitches
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 7.6 (2010.12)
Hardware: Other All
: medium normal
Assignee: Chris Wilson
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 36041 (view as bug list)
Depends on:
Blocks:
 
Reported: 2011-03-30 10:42 UTC by Georg Grabler
Modified: 2011-05-01 15:27 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments
dmesg output (46.22 KB, text/plain)
2011-03-30 10:43 UTC, Georg Grabler
no flags Details
intel reg dump (11.17 KB, text/plain)
2011-03-30 10:44 UTC, Georg Grabler
no flags Details
vbios dump (64.00 KB, application/octet-stream)
2011-03-30 10:45 UTC, Georg Grabler
no flags Details
xorg log (44.56 KB, text/plain)
2011-03-30 10:45 UTC, Georg Grabler
no flags Details
xorg.conf (but same errors without) (2.33 KB, text/plain)
2011-03-30 10:46 UTC, Georg Grabler
no flags Details
xrandr verbose (6.98 KB, text/plain)
2011-03-30 10:46 UTC, Georg Grabler
no flags Details
photo of the graphic glitches (102.54 KB, image/jpeg)
2011-03-30 10:56 UTC, Georg Grabler
no flags Details
photo of the problem on the notebook screen (79.42 KB, image/jpeg)
2011-03-30 10:57 UTC, Georg Grabler
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Georg Grabler 2011-03-30 10:42:33 UTC
Hello,

I bought a Dell Latitude e6420, which includes a I5 2520, with a HD 3000 card by Intel.

Now, the Intel drivers seem to have a LOT of flaws, which I will try to describe here, doing full backtraces, and providing all information requested. I'll start out with the "how to report bugs" thingy:

Chipset
I don't know, but lspci shows "00:02.0 VGA compatible controller: Intel Corporation Device 0126 (rev 09)", maybe it helps

System Architecture
x86_64

Driver / Lib Versions
All built by Chakra-Linux guys (chakra testing repository)
xf86-video-intel 2.14.0
xorg-server 1.9.5
mesa 7.10
libdrm 2.4.23

Kernel Version
kernel26 2.6.38.2

Linux Distribution
Chakra Linux: [testing] repository (don't worry, stable doesn't work too, nor does openSuSE)


Machine or mobo model:
I just know it's a Dell Latitude e6420

Display Connector:
External Monitor: VGA
Laptop Monitor: LVDS

Steps to reproduce:
Boot up your computer. It happens no matter if an external monitor is connected or not. When the kernel modules are loaded, your laptop screen turns black, with a few white stripes on the right side (I'll provide pictures).

If you have an external monitor connected, XOrg will come up - just not on the laptop screen, but on the VGA screen (which works properly all the time).

After you log in, I recommend to disable the output to LVDS, since it definitely damages something in the system keeping it for too long (my display flickered for hours after having it enabled for a while, even when the bios screen came it flickered. Luckily, this was gone on the next day).
Comment 1 Georg Grabler 2011-03-30 10:43:12 UTC
Created attachment 45054 [details]
dmesg output
Comment 2 Georg Grabler 2011-03-30 10:44:39 UTC
Created attachment 45055 [details]
intel reg dump
Comment 3 Georg Grabler 2011-03-30 10:45:05 UTC
Created attachment 45057 [details]
vbios dump
Comment 4 Georg Grabler 2011-03-30 10:45:29 UTC
Created attachment 45058 [details]
xorg log
Comment 5 Georg Grabler 2011-03-30 10:46:05 UTC
Created attachment 45059 [details]
xorg.conf (but same errors without)
Comment 6 Georg Grabler 2011-03-30 10:46:30 UTC
Created attachment 45060 [details]
xrandr verbose
Comment 7 Georg Grabler 2011-03-30 10:56:38 UTC
Created attachment 45061 [details]
photo of the graphic glitches
Comment 8 Georg Grabler 2011-03-30 10:57:16 UTC
Created attachment 45062 [details]
photo of the problem on the notebook screen
Comment 9 Georg Grabler 2011-03-31 00:34:23 UTC
Okay, I created another bug (as requested by ickle) for the KMS problem, and we will use this for the KDE Display problem.

The bug for KMS is: https://bugs.freedesktop.org/show_bug.cgi?id=35812
Comment 10 Georg Grabler 2011-03-31 00:35:05 UTC
Comment on attachment 45062 [details]
photo of the problem on the notebook screen

obsolete -> KMS problems
https://bugs.freedesktop.org/show_bug.cgi?id=35812
Comment 11 Kenneth Graunke 2011-04-02 19:49:47 UTC
I can reproduce this issue with Mesa master, libdrm 2.4.24, xf86-video-intel 2.14.902, and kernel 2.6.38.

Enabling DebugFlushBatches corrects the issue: KDE's menus draw correctly if I add the following to xorg.conf.d:

Section "Device"
    Identifier "Sandybridge"
    Driver "intel"
    Option "DebugFlushBatches" "True"
EndSection

I also tried DebugFlushCaches; it seems to have no effect on this issue.

Let me know if I can help provide any further info.
Comment 12 Georg Grabler 2011-04-03 05:03:06 UTC
I can confirm the workaround Kenneth describes, works properly here as well.
Comment 13 Chris Wilson 2011-04-04 09:07:48 UTC
Flush batches does fix part of the issue here, a bug that is reminiscent of an old i915 glitch.

It so far has resisted being root caused.
Comment 14 Chris Wilson 2011-04-06 22:45:49 UTC
*** Bug 36041 has been marked as a duplicate of this bug. ***
Comment 15 christian.hersevoort 2011-04-07 01:44:32 UTC
I confirm adding "DebugFlushBatches" to xorg config fixes my problem, thanks! 

Sorry for the duplicate bug, I searched through the bugs but didn't find a (close) match. (But this one is)
Comment 16 Scott Kitterman 2011-04-08 16:15:10 UTC
I have a Dell Latitude e6320 (which is very similar).  I have a similar problem to the one described here in KDE, but not the KMS issue.  Setting Option "DebugFlushBatches" "True" was an effective work around for me.

Current Kubuntu Natty with:
xorg-server | 1.10.0
mesa | 7.10.1
libdrm | 2.4.23
xserver-xorg-video-intel | 2.14.0
linux | 2.6.38.8.22
Comment 17 Olaf Freyer 2011-04-11 10:03:30 UTC
I were experiencing the exact same issues.

I still saw them using xf86-video-intel-2.14.902, but just now switched to xf86-video-intel-2.14.903 and they are gone!
Comment 18 Chris Wilson 2011-04-11 10:57:53 UTC
Well, I knew it was a bug, just wasn't the bug I was searching for at the time! :)

commit 25521900df11bc71020ee80db2223f979bec5ec6
Author: Chris Wilson <chris@chris-wilson.co.uk>
Date:   Thu Apr 7 15:09:30 2011 +0100

    gen6: Invalidate texture cache
    
    Signed-off-by: Chris Wilson <chris@chris-wilson.co.uk>
Comment 19 younker 2011-04-16 22:17:45 UTC
I just upgraded the driver to 2.15 yesterday, but I still got the same error on KDE 4.6.2. Besides the driver, what else do I need to upgrade to get this problem solved?
Comment 20 Chris Wilson 2011-04-16 22:26:09 UTC
(In reply to comment #19)
> I just upgraded the driver to 2.15 yesterday, but I still got the same error on
> KDE 4.6.2. Besides the driver, what else do I need to upgrade to get this
> problem solved?

First the obvious question, are you sure it is the same bug? 3 different people reproducing and verifying the same fix does suggest that one bug was resolved.

Have you checked that you are using the driver version you think you are? (Does Xorg.log confirm that you installed the driver correctly?)

If I had to guess, I would say the latter. By default the driver installs itself into /usr/lib/xorg/modules/drivers, but your system (which you give no details for) might be using /usr/lib64/xorg/modules/drivers...
Comment 21 younker 2011-04-17 00:48:31 UTC
Thanks Chris, 

From the screenshot, I think this is the same issue. from my Xorg.log, I am sure that I use intel driver,  also the installation path is correct. my /usr/lib/ is symlink to /usr/lib64. 

My notebook is Acer 3750G with a nvidia GT520M display card. But from the kernel to xorg setting, I disable all nvidia related option. 

Buy the way, with Option "DebugFlushBatches" "True",  the problem of glitch doesn't appear. 

My CPU is Core 2 i3 2310M. 

(In reply to comment #20)
> (In reply to comment #19)
> > I just upgraded the driver to 2.15 yesterday, but I still got the same error on
> > KDE 4.6.2. Besides the driver, what else do I need to upgrade to get this
> > problem solved?
> 
> First the obvious question, are you sure it is the same bug? 3 different people
> reproducing and verifying the same fix does suggest that one bug was resolved.
> 
> Have you checked that you are using the driver version you think you are? (Does
> Xorg.log confirm that you installed the driver correctly?)
> 
> If I had to guess, I would say the latter. By default the driver installs
> itself into /usr/lib/xorg/modules/drivers, but your system (which you give no
> details for) might be using /usr/lib64/xorg/modules/drivers...
Comment 22 Georg Grabler 2011-05-01 15:27:14 UTC
I today updated as well - the problems are gone for me too.

I updated:
libdrm 2.4.23 -> 2.4.25
mesa 7.10 -> 7.10.2
intel-dri 7.10 -> 7.10.2
xf86-video-intel 2.14.902 -> 2.15.0


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.